Hello bimmer fans.

I have a very frustrating problem that I could not find solution anywhere on internet so I have my hopes in you guys.
It sounds like this:

First it happened 2 years ago, when in nice hot morning, after the car was staying for 2 days I was having a flat battery. I charged it, put it up, the car started, everything was fine for months, when it happened again. Had the same intermitent problem until 1 month ago, it started to discharge the battery over the night and now because I had charged the battery so many times, it is not holding a full charge, so with the battery fully charged it is discharging it in 2 hours.

The main suspect is the klima unit. It seems that is having a small blower motor in it witch is responsible for ambient air temp. It takes the air from cabin and send it in the back to ambient temp sensor. Now this small motor is working all the time, even if I remove the key from contact.

- I have bought a new clima unit and the problem is still the same, no differece, the motor keeps rolling.
- Today I had bought a new battery also.

My main question is: Maybe this one was suppose to work all the time and the central saving is not working anymore so it allows this element to suck all the life from the battery in days (from a new battery).

I could not find a central saving relay, all the searches lead finally to the general module.
The doors do not deadlock anymore also so if i close myself in the car and stay for 15 minutes I`m still able to unlock the doors from the lever or lock/unlock button from central console, even open/close the windows and this wasn`t posible some time ago. Once the car was locked from the remote everything was dead inside.
Do you think this 2 problems are linked? Should I change the relays from the GM>? The car locks and unloks just fine.
What should i check?