Battery change

Notices
 

Thread: Battery change

Reply to Thread
Results 1 to 7 of 7
  1. Battery change 
    #1
    Bimmer Fan
    Join Date
    Jun 2008
    Location
    Blyth
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi all,
    I have a 1997 BMW535 [BM75043] & have just replaced the battery, I now have a car that switches the radio on & off whenever it pleases & the indicators on the dash are also intermittent. I have had fault codes removed at the local garage & a new ignition switch fitted to no avail. If I disconnect the battery & leave it for a while everything works fine for a few seconds then goes back to its intermittent faults, any ideas?

    Thank you
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,398
    Thanks
    6,198
    Thanked 7,052 Times in 5,322 Posts
    Why was the battery replaced? was the charging rate checked afterwards?
     
     

  4.  
    #3
    Bimmer Fan
    Join Date
    Jun 2008
    Location
    Blyth
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    The old battery was replaced as it wasn't holding a charge, left it on a ctek charger for a few days but no change, new battery is fine as is the charge rate. All ok today apart from the sunroof has stopped working! All fuses checked & ok, annoying fault as its all intermittent, checking all earthing points at the moment.
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Bimmer Fan
    Join Date
    Jun 2008
    Location
    Blyth
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts


    The saga goes on, 'check rear fog lights' came on today & all the faults have cleared, radio & indicators on the dash are working again. I can put up with the fault so going to leave well alone! Would still be interested in any thoughts though.
     
     

  7.  
    #5
    Bimmerforums Central
    Car Details
    Boostist's Car Details
    Model of Car:
    E46 320i
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    Boostist's Avatar
    Join Date
    Sep 2004
    Location
    Uk
    Posts
    8,035
    Thanks
    3,347
    Thanked 3,427 Times in 1,481 Posts
    Quote Originally Posted by chieftyson View Post


    The saga goes on, 'check rear fog lights' came on today & all the faults have cleared, radio & indicators on the dash are working again. I can put up with the fault so going to leave well alone! Would still be interested in any thoughts though.
    Check the alternators output...

    It should be around 14volts iirc with engine running, then put lights and all accessories on and see what it drops too, shouldnt drop much if at all...

    Heres how to test it...its easy to do

    testing alternator
     
     

  8.  
    #6
    Bimmer Fan
    Join Date
    Jun 2008
    Location
    Blyth
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Did what you said & all ok, 'check fog lights' off today & old faults returned, I have focused on the battery & the light cluster next to it but not on the otherside, guess what, when I opened the other rear panel I found two leads for the cd changer, not fitted, submerged in a inch of water. Have dried out the compartment & now all ok!
    thanks for your help, I should've looked earlier!
     
     

  9.  
    #7
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,398
    Thanks
    6,198
    Thanked 7,052 Times in 5,322 Posts
    Quote Originally Posted by chieftyson View Post
    Did what you said & all ok, 'check fog lights' off today & old faults returned, I have focused on the battery & the light cluster next to it but not on the otherside, guess what, when I opened the other rear panel I found two leads for the cd changer, not fitted, submerged in a inch of water. Have dried out the compartment & now all ok!
    thanks for your help, I should've looked earlier!
    , you could sit there all day going through things to check and not solve it, problems like this really are unique, Glad to hear you solved it, I always knew it was a water puddle in the boot ........
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts