2007 E92 335i, Rear Windscreen De-mister not working

Notices
 

Thread: 2007 E92 335i, Rear Windscreen De-mister not working

Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 20
  1. 2007 E92 335i, Rear Windscreen De-mister not working 
    #1
    Bimmer Fan
    Car Details
    The_MC's Car Details
    Model of Car:
    335i M Sport
    Year of Manufacture:
    2007
    Transmission Type:
    Steptronic
    Car Body Type:
    Coupe

    Join Date
    Jan 2012
    Location
    Nottingham
    Posts
    21
    Thanks
    1
    Thanked 3 Times in 3 Posts
    Hi,

    I bought my 335i coupe about a month ago now. When i was checking it out in the showroom the battery light displayed and gave the warning that the battery voltage was low. A few minutes afterwards it shut down the i drive screen and stereo.

    Upon purchasing i raised this with the dealer and they said if it becomes a problem they would replace the battery. The weekend afterwards i noticed the rear-demister was not working and sometimes the heated seats stopped working several minutes after turning them on. In radio readiness i still had the battery low voltage warning and it shut everything down when the engine was not running.

    I called the dealer and he said he would replace the battery. I argued that there was more to it than that and he had it in at a auto electrician to test the system. Auto electrician diagnosed the alternator was at fault. The dealer as had the car nearly a week now, as they said they were waiting for an alternator to arrive.

    Does this ring any alarms bells with you guys or could this be something else. Looking a for a second opinion i suppose.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Maestro
    Car Details
    cforehead's Car Details
    Model of Car:
    335d M Sport
    Year of Manufacture:
    2008
    Transmission Type:
    Auto
    Car Body Type:
    Coupe
    cforehead's Avatar
    Join Date
    Jul 2009
    Location
    North Devon
    Posts
    724
    Thanks
    298
    Thanked 453 Times in 396 Posts
    I'm no expert but I know that a faulty/dead battery can do more than just prevent a car from starting these days, so the errors/problems you've encountered seem feasible.

    If the dealer are sourcing an alternator then surely they're covering both bases? I guess it's more the delay that your peeved at rather than the issue itself.

    Is this a BMW dealer?

    2008 335d M Sport Coupe
     
     

  4.  
    #3
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    The IBS is shutting down all the non-essentials in the car due to low charge state of battery. So bo need to worry on that front.
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Bimmer Fan
    Car Details
    The_MC's Car Details
    Model of Car:
    335i M Sport
    Year of Manufacture:
    2007
    Transmission Type:
    Steptronic
    Car Body Type:
    Coupe

    Join Date
    Jan 2012
    Location
    Nottingham
    Posts
    21
    Thanks
    1
    Thanked 3 Times in 3 Posts
    Thanks guys......see what happens when i finally get it back. They've had it since last Thursday.
     
     

  7.  
    #5
    Bimmer Fan
    Car Details
    The_MC's Car Details
    Model of Car:
    335i M Sport
    Year of Manufacture:
    2007
    Transmission Type:
    Steptronic
    Car Body Type:
    Coupe

    Join Date
    Jan 2012
    Location
    Nottingham
    Posts
    21
    Thanks
    1
    Thanked 3 Times in 3 Posts
    Guys,

    Quick update! Picked car up this morning after explicitly asking them if the alternator had fixed the problem. They, of course, assured me it had. Got in the car this morning and surprise surprise, the car lasts for about 2 minutes, without the engine running, before it shuts down all the idrive and radio. Not sure if the rear de-mister is working yet but time will tell.

    I raised this with the owner of the dealer and he said see how it goes this weekend and call him on monday.

    Surely a bmw can run the radio and the idrive off the battery for longer than to minutes without complaining about low battery voltage.

    Help!
     
     

  8.  
    #6
    BMW Maestro
    Car Details
    cforehead's Car Details
    Model of Car:
    335d M Sport
    Year of Manufacture:
    2008
    Transmission Type:
    Auto
    Car Body Type:
    Coupe
    cforehead's Avatar
    Join Date
    Jul 2009
    Location
    North Devon
    Posts
    724
    Thanks
    298
    Thanked 453 Times in 396 Posts
    Yes, certainly an issue there. Is it a BMW dealer? If yes I'd be onto the dealer principal if it turns out they've told you they've completed work which they haven't...

    2008 335d M Sport Coupe
     
     

  9.  
    #7
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    One thing you can do is check the voltage in the hidden menu to see if the battery is being charged....http://www.bimmerforums.co.uk/forum/...others-t71807/ . The voltage should be around 14.4 volts and when car iswitched off, it should drop to 12.2V and hold steady there. This is the range the IBS looks at.
     
     

  10.  
    #8
    Bimmer Fan
    Car Details
    The_MC's Car Details
    Model of Car:
    335i M Sport
    Year of Manufacture:
    2007
    Transmission Type:
    Steptronic
    Car Body Type:
    Coupe

    Join Date
    Jan 2012
    Location
    Nottingham
    Posts
    21
    Thanks
    1
    Thanked 3 Times in 3 Posts
    Nah not a dealer its a sports performance dealer but i seen the owner today. I have to call him on Monday to let him know if the problem is still there, which i think it probably still will be.
     
     

  11.  
    #9
    Bimmer Fan
    Car Details
    The_MC's Car Details
    Model of Car:
    335i M Sport
    Year of Manufacture:
    2007
    Transmission Type:
    Steptronic
    Car Body Type:
    Coupe

    Join Date
    Jan 2012
    Location
    Nottingham
    Posts
    21
    Thanks
    1
    Thanked 3 Times in 3 Posts
    Quote Originally Posted by NealP View Post
    One thing you can do is check the voltage in the hidden menu to see if the battery is being charged....http://www.bimmerforums.co.uk/forum/...others-t71807/ . The voltage should be around 14.4 volts and when car iswitched off, it should drop to 12.2V and hold steady there. This is the range the IBS looks at.
    Thanks NealP i'll check this out as soon as i can and let you know the results.
     
     

  12.  
    #10
    Bimmer Fan
    Car Details
    The_MC's Car Details
    Model of Car:
    335i M Sport
    Year of Manufacture:
    2007
    Transmission Type:
    Steptronic
    Car Body Type:
    Coupe

    Join Date
    Jan 2012
    Location
    Nottingham
    Posts
    21
    Thanks
    1
    Thanked 3 Times in 3 Posts
    UPDATE!

    Everything working now....seemed to be after taking the car for a run to re-charge the battery i imagine. Even the home lights come on when unlocking the car, residual heater working now also. I assume the re-demister is working, i never wanted it to freeze so much than i do now so i can try it out.

    Still gonna check out the hidden menus though!.

    Thanks guys!
     
     

Page 1 of 2 12 LastLast
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts