2007 E60 520d - Radio channels crackling when heated rear window is on.

Notices
 

Thread: 2007 E60 520d - Radio channels crackling when heated rear window is on.

Reply to Thread
Results 1 to 10 of 10
  1. 2007 E60 520d - Radio channels crackling when heated rear window is on. 
    #1
    Bimmer Fan
    Car Details
    craig g's Car Details
    Model of Car:
    520d msport
    Year of Manufacture:
    07
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    May 2011
    Location
    merseyside
    Posts
    21
    Thanks
    6
    Thanked 2 Times in 2 Posts
    has anyone come across this before ?? if i have the radio on and the heated rear window then the signal seems to be weakened.switch the rear off and its back to clear audio.doesnt happen when the lights are on or the A/C is switched on etc,just the heated rear window.HELP PLEASE
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Crazed
    Car Details
    Garyslee's Car Details
    Model of Car:
    E36 328i cab M3 replica
    Year of Manufacture:
    1996
    Transmission Type:
    manual
    Car Body Type:
    convertible
    Garyslee's Avatar
    Join Date
    Jun 2010
    Location
    nottingham
    Posts
    160
    Thanks
    46
    Thanked 101 Times in 71 Posts
    What car?
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    craig g's Car Details
    Model of Car:
    520d msport
    Year of Manufacture:
    07
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    May 2011
    Location
    merseyside
    Posts
    21
    Thanks
    6
    Thanked 2 Times in 2 Posts
    sorry mate its a 2007 520d msport.
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Premium Member
    Car Details
    matthew_henson's Car Details
    Model of Car:
    E61 525d Touring
    Year of Manufacture:
    2005
    Transmission Type:
    Manual
    Car Body Type:
    Touring/Estate
    matthew_henson's Avatar
    Join Date
    Mar 2011
    Location
    Forest Of Dean
    Posts
    4,210
    Thanks
    904
    Thanked 1,412 Times in 1,223 Posts
    Quote Originally Posted by craig g View Post
    sorry mate its a 2007 520d msport.
    Radio antenna is built in the rear heated window element, you either have a bad connections somewhere or the suppressor has blown (little capacitor)

    Check all the connections and connectors first and if that does work try adding another suppressor
     
     

  7. The Following User Says Thank You to matthew_henson For This Useful Post:

    craig g (12-08-2011)

  8.  
    #5
    BMW Master
    Car Details
    Doyler's Car Details
    Model of Car:
    330D Sport
    Year of Manufacture:
    2003
    Transmission Type:
    Auto
    Car Body Type:
    Saloon
    Doyler's Avatar
    Join Date
    Jul 2010
    Location
    Sandhurst
    Posts
    264
    Thanks
    115
    Thanked 80 Times in 62 Posts
    Quote Originally Posted by craig g View Post
    has anyone come across this before ?? if i have the radio on and the heated rear window then the signal seems to be weakened.switch the rear off and its back to clear audio.doesnt happen when the lights are on or the A/C is switched on etc,just the heated rear window.HELP PLEASE
    This also happens on my E46. As above or it can apparently be caused by a break in the heater element itself. Not sure how true that is. I just put a CD on while the window clears.
    Swirl Flaps Done
    Central Locking Fixed
    FK452's Fitted
     
     

  9. The Following User Says Thank You to Doyler For This Useful Post:

    craig g (12-08-2011)

  10.  
    #6
    Moderator
    Car Details
    thepurpleblob's Car Details
    Model of Car:
    840Ci Sport, 330Ci Clubsport, X3 2.0d SE
    Year of Manufacture:
    1999, 2003, 2004
    Transmission Type:
    Automatic, Automatic, Manual
    Car Body Type:
    Coupe, Coupe, SAV
    thepurpleblob's Avatar
    Join Date
    Aug 2010
    Location
    Carluke, Lanarkshire (nr. Glasgow)
    Posts
    1,903
    Images
    1
    Thanks
    96
    Thanked 443 Times in 402 Posts
    I could be talking rubbish but I don't think a 2007 E60 has the antenna in the glass. There are loads of different antenna depending on what phone/media pack/tuner you happen to have. You should either have the "shark fin" antenna or the diversity antenna (which sits at the top of the rear screen I think).

    There are a few things to go wrong. The shark-fin has an amplifier in it and it's in a prime position for water ingress. The diversity tuner has a filter behind one of the c (d?) post covers. This is just off the top of my head.
     
     

  11. The Following User Says Thank You to thepurpleblob For This Useful Post:

    craig g (12-08-2011)

  12.  
    #7
    Bimmer Fan
    Car Details
    diskodee's Car Details
    Model of Car:
    320d
    Year of Manufacture:
    2005
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    Aug 2011
    Location
    scotland
    Posts
    16
    Thanks
    4
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by craig g View Post
    has anyone come across this before ?? if i have the radio on and the heated rear window then the signal seems to be weakened.switch the rear off and its back to clear audio.doesnt happen when the lights are on or the A/C is switched on etc,just the heated rear window.HELP PLEASE
    i have this problem aswell did u manage to fix it
     
     

  13.  
    #8
    Bimmer Fan
    Car Details
    craig g's Car Details
    Model of Car:
    520d msport
    Year of Manufacture:
    07
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    May 2011
    Location
    merseyside
    Posts
    21
    Thanks
    6
    Thanked 2 Times in 2 Posts
    Quote Originally Posted by diskodee View Post
    i have this problem aswell did u manage to fix it
    no mate,only noticed it coming home this morning so i will be giving my mate a all saturdat (i work permanent nights and had a right sleep in today lol) will post back when i have more info.

    thanks for all the replys btw.

    p.s it is the shark fin aeial btw.
     
     

  14.  
    #9
    Bimmer Fan
    Car Details
    craig g's Car Details
    Model of Car:
    520d msport
    Year of Manufacture:
    07
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    May 2011
    Location
    merseyside
    Posts
    21
    Thanks
    6
    Thanked 2 Times in 2 Posts
    Quote Originally Posted by E46330DSport View Post
    This also happens on my E46. As above or it can apparently be caused by a break in the heater element itself. Not sure how true that is. I just put a CD on while the window clears.
    after spending 18k on a second hand car i will be damned if im putting up with doin that lol.
     
     

  15.  
    #10
    Platinum BFuk Member
    Car Details
    sam1832's Car Details
    Model of Car:
    318ci
    Year of Manufacture:
    2004
    Transmission Type:
    manual
    Car Body Type:
    convertable Msport
    sam1832's Avatar
    Join Date
    May 2010
    Location
    essex
    Posts
    2,578
    Thanks
    407
    Thanked 811 Times in 675 Posts
    after i broke the ariel cable, while puting the HU back,

    I had to replace the cable all the way from the HU to the back, a bit of a pain in the ass but after putting all the trim and boot lining back,

    i was driving and turned the rear screen on, interfrenece with the radio

    i can only assume that i have run the cable with the heated screen wireing, i cant really be bothered to pull the car to bits again tho
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts