2006 e61 525d - IDrive (radio, gps...) out of order

Notices
 

Thread: 2006 e61 525d - IDrive (radio, gps...) out of order

Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. 2006 e61 525d - IDrive (radio, gps...) out of order 
    #1
    Bimmer Fan
    Car Details
    Mal_Y's Car Details
    Model of Car:
    525d
    Year of Manufacture:
    2006
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Jan 2011
    Location
    Oulu, Finland
    Posts
    7
    Thanks
    1
    Thanked 1 Time in 1 Post
    Hello!

    Does anyone have had problem with Idrive?

    My problem started first when driving on a bumpy road: Idrive made restart that lasted about 10-30 seconds and then it worked normally...

    2 days ago it went totally out of order when driving an a normal road and it hasn't started since.

    I found some hints for this from this forum. So, I got the ccc-unit out and opened it and checked all the cables like was described:
    http://www.bimmerforums.co.uk/forum/...pictureid=5476
    http://www.bimmerforums.co.uk/forum/...pictureid=5477

    No luck. Idrive doesn't work at all.

    So, does anyone have any ideas?

    Thanks in advance.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Dr of BMW
    Car Details
    530kam's Car Details
    Model of Car:
    530d M Sport
    Year of Manufacture:
    2005
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon
    530kam's Avatar
    Join Date
    Aug 2010
    Location
    Buckinghamshire
    Posts
    1,032
    Thanks
    425
    Thanked 315 Times in 280 Posts
    some people have suggested the iDrive is very sensitive to battery fluctuations - have you checked your battery?
    Bavarian Motor Works
    530d M Sport Auto in Carbon Black with Black Leather

    Options: Sat Nav Professional,Bluetooth,Folding rear seats, Playstation II, Sony 10 DVD player, Twin headrest monitors & wireless headphones
    Modifications: De flapped,Spare wheel kit, Falken 452's,retrofit BMW Ipod & full software upgrade
    Wish List: window tints & spoiler
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    Mal_Y's Car Details
    Model of Car:
    525d
    Year of Manufacture:
    2006
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Jan 2011
    Location
    Oulu, Finland
    Posts
    7
    Thanks
    1
    Thanked 1 Time in 1 Post
    Hi..

    I have checked that charging works properly, but haven't checked the battery itself.
    Was it so, that if I change the battery it's needed to tell to the car, so that it knows that there is a new battery?
    Last edited by Mal_Y; 27-01-2011 at 10:41. Reason: typo
     
     

  5.  
    #4
    Dr of BMW
    Car Details
    530kam's Car Details
    Model of Car:
    530d M Sport
    Year of Manufacture:
    2005
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon
    530kam's Avatar
    Join Date
    Aug 2010
    Location
    Buckinghamshire
    Posts
    1,032
    Thanks
    425
    Thanked 315 Times in 280 Posts
    read the e60 technical section - there is a thread about iDrives not working - some have had the batteries replaced by garages and others have replaced the batteries themselves - good luck and let us know how you fixed it. helps others
    Bavarian Motor Works
    530d M Sport Auto in Carbon Black with Black Leather

    Options: Sat Nav Professional,Bluetooth,Folding rear seats, Playstation II, Sony 10 DVD player, Twin headrest monitors & wireless headphones
    Modifications: De flapped,Spare wheel kit, Falken 452's,retrofit BMW Ipod & full software upgrade
    Wish List: window tints & spoiler
     
     

  6. The Following User Says Thank You to 530kam For This Useful Post:

    mark@vorny.co.uk (27-01-2011)

  7.  
    #5
    Bimmer Fan
    Car Details
    Mal_Y's Car Details
    Model of Car:
    525d
    Year of Manufacture:
    2006
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Jan 2011
    Location
    Oulu, Finland
    Posts
    7
    Thanks
    1
    Thanked 1 Time in 1 Post
    Quote Originally Posted by 530kam View Post
    read the e60 technical section - there is a thread about iDrives not working - some have had the batteries replaced by garages and others have replaced the batteries themselves - good luck and let us know how you fixed it. helps others
    Ok. Finally something to update here...

    Few weeks ago I took the CCC module out from my car and tried to find the problem with it (this is because I read A LOT of topics from BMW sites and that was a problem for many...).

    For 5 evenings I measured the circuit boards and components, etc. I also used a small 12VDC power source to get see better where the problem might be.

    => NO HELP!

    All I got was from the ccc unit power circuit board. There are 2 regulators and the other one seems to be working (all power are there, etc.) but the other is missing the Vcc (12 VDC). There is 1 "chip" that gives the power to it, but there is a logic control for it to give power onwards. That logic line is 'down' and so it's not giving power to the other regulator.

    I tried few tricks with it, but nothing.
    So, this morning my car went to bmw repair and they are changing the whole CCC module and softwares are updated also.

    Cost in Finland: 1050 € (new module 850 + installations + software update). NICE!

    I have some pictures of the circuit boards and some other stuff too.
    So, if you want to know something else, just ask...I will tell everything I know about this, but I have no solution to repair it.
     
     

  8.  
    #6
    Dr of BMW
    Car Details
    530kam's Car Details
    Model of Car:
    530d M Sport
    Year of Manufacture:
    2005
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon
    530kam's Avatar
    Join Date
    Aug 2010
    Location
    Buckinghamshire
    Posts
    1,032
    Thanks
    425
    Thanked 315 Times in 280 Posts
    please do share what you have - it may help someone in the future
    Bavarian Motor Works
    530d M Sport Auto in Carbon Black with Black Leather

    Options: Sat Nav Professional,Bluetooth,Folding rear seats, Playstation II, Sony 10 DVD player, Twin headrest monitors & wireless headphones
    Modifications: De flapped,Spare wheel kit, Falken 452's,retrofit BMW Ipod & full software upgrade
    Wish List: window tints & spoiler
     
     

  9.  
    #7
    Bimmer Fan
    Car Details
    Mal_Y's Car Details
    Model of Car:
    525d
    Year of Manufacture:
    2006
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Jan 2011
    Location
    Oulu, Finland
    Posts
    7
    Thanks
    1
    Thanked 1 Time in 1 Post
    Ok.

    Here's a picture of a CCC modules power circuit board where you can see the 2 regulators that I found - other one is working and the other is not, because of missing Vcc.
    Regulator is LTC1735 (datasheet attached)...

    I have a picture of that other chip too, which has the logic line on it, but it's on my other computer so I'll attach it later.
    Attached Images
    Attached Files
    Last edited by Mal_Y; 04-04-2011 at 08:27. Reason: Typo...
    Driving:
    E61 525d, 01/2006

    EX's:
    E87 116i, 2007
    E36 320i Coupe, 1995
    E21 318i, 1982
    MB W115 240D, 1975
     
     

  10.  
    #8
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    What pin on the regulator is missing the voltage?
     
     

  11.  
    #9
    Bimmer Fan
    Car Details
    Mal_Y's Car Details
    Model of Car:
    525d
    Year of Manufacture:
    2006
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Jan 2011
    Location
    Oulu, Finland
    Posts
    7
    Thanks
    1
    Thanked 1 Time in 1 Post
    Quote Originally Posted by NealP View Post
    What pin on the regulator is missing the voltage?
    Pin 13 (Vin) - Input Supply Voltage.
    Driving:
    E61 525d, 01/2006

    EX's:
    E87 116i, 2007
    E36 320i Coupe, 1995
    E21 318i, 1982
    MB W115 240D, 1975
     
     

  12. The Following User Says Thank You to Mal_Y For This Useful Post:

    530kam (07-04-2011)

  13.  
    #10
    BMW Guru
    Car Details
    joylove's Car Details
    Model of Car:
    328
    Year of Manufacture:
    1998
    Transmission Type:
    Manual
    Car Body Type:
    cabrio

    Join Date
    Sep 2010
    Location
    UK
    Posts
    1,500
    Thanks
    108
    Thanked 466 Times in 366 Posts
    The rails might be down because it's not fully powered on to conserve the battery life. You would want it in the car and supposedly in a working mode for that test. If you tie the logic line to ENABLED with a 1k resistor as a test does the unit start performing correctly?
     
     

Page 1 of 2 12 LastLast
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts