2006 E46 318ci Fiddled with the stereo and now the airbag warning light is on!!!

Notices
 

Thread: 2006 E46 318ci Fiddled with the stereo and now the airbag warning light is on!!!

Reply to Thread
Results 1 to 6 of 6
  1. 2006 E46 318ci Fiddled with the stereo and now the airbag warning light is on!!! 
    #1
    BMW Master
    Car Details
    StreetTriple's Car Details
    Model of Car:
    318ci M Sport
    Year of Manufacture:
    2006
    Transmission Type:
    manual
    Car Body Type:
    convertible
    StreetTriple's Avatar
    Join Date
    Jul 2009
    Location
    Glasgow, Scotland
    Posts
    285
    Thanks
    64
    Thanked 39 Times in 37 Posts
    My own fault as I the one time I didn't disconnect the battery to remove the wiring behind the stereo to check changer plug and now the airbag warning light is on!
    Doesn't make sense to me is there any reason why this has happened? I guess it will need to stay on until it's due it's next service?? Or is there a diy fix without a code reader tool??
    HID Conversion, M Power numberplate surrounds, Intravee II and Alpine KCA 420i linked to iPod, De badged, clayed, and polished to perfection!
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BFuk Moderator
    Car Details
    Martyn D.'s Car Details
    Model of Car:
    330 ci
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    coupe
    Martyn D.'s Avatar
    Join Date
    May 2009
    Location
    Cambridgeshire
    Posts
    2,681
    Thanks
    2,478
    Thanked 3,484 Times in 2,111 Posts
    Try disconnecting the battery and leave for 10 minutes.... may do the trick
     
     

  4.  
    #3
    BMW Master
    Car Details
    Bmw techy's Car Details
    Model of Car:
    325ci
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Nov 2009
    Location
    westmidlands
    Posts
    317
    Thanks
    2
    Thanked 84 Times in 70 Posts
    will need reseting with someone with the tools, bmw dealer or decent indy
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    BMW Master
    Car Details
    StreetTriple's Car Details
    Model of Car:
    318ci M Sport
    Year of Manufacture:
    2006
    Transmission Type:
    manual
    Car Body Type:
    convertible
    StreetTriple's Avatar
    Join Date
    Jul 2009
    Location
    Glasgow, Scotland
    Posts
    285
    Thanks
    64
    Thanked 39 Times in 37 Posts
    Yeah but anybody know why it is on, I only disconnected the block connector at the rear of the stereo and then re joined it nothing else.
    Are these two somehow connected???

    And appologies to the moderator I came back on to update the title thread with my cars details but you had already beat me to it! Thanks!
    HID Conversion, M Power numberplate surrounds, Intravee II and Alpine KCA 420i linked to iPod, De badged, clayed, and polished to perfection!
     
     

  7.  
    #5
    BMW Fanatic
    Car Details
    beam99's Car Details
    Model of Car:
    318i
    Year of Manufacture:
    1999
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    Jul 2009
    Location
    ireland
    Posts
    37
    Thanks
    0
    Thanked 7 Times in 6 Posts
    Maybe you have a bad connections on one of the airbag wires on ur seat, and with moving around on the seat just triggered it, I had a problem before with my seatbelt receiver, and when i unclipped the belt from the receiver the light would come on.
     
     

  8.  
    #6
    BMW Master
    Car Details
    StreetTriple's Car Details
    Model of Car:
    318ci M Sport
    Year of Manufacture:
    2006
    Transmission Type:
    manual
    Car Body Type:
    convertible
    StreetTriple's Avatar
    Join Date
    Jul 2009
    Location
    Glasgow, Scotland
    Posts
    285
    Thanks
    64
    Thanked 39 Times in 37 Posts
    Thanks for the idea but I thnk it has more to do with the wiring of the stereo, dunno why I think that, probably as my car is a 2006 with only 20k on the clock so don't think I should be having problems like this from the car (unless some tw*t is screwng abou with the wiring with the battery still connected!!!!)
    HID Conversion, M Power numberplate surrounds, Intravee II and Alpine KCA 420i linked to iPod, De badged, clayed, and polished to perfection!
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts