2005 E90 320d - no radio recption.

Notices
 

Thread: 2005 E90 320d - no radio recption.

Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. 2005 E90 320d - no radio recption. 
    #1
    Bimmer Fan
    Car Details
    merlin4x4's Car Details
    Model of Car:
    320d es
    Year of Manufacture:
    2005
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    May 2011
    Location
    guisborough
    Posts
    9
    Thanks
    2
    Thanked 0 Times in 0 Posts
    hi all.
    i have just bought my first bmw a 2005 e90 320d es. so far so good except the radio recption is not very good, i was told that it may be the fuse for the antenna amp but when i looked in the fuse box the diagram is missing so i dont know wich fuse to check. also dose anyone know where i can get a fuse box diagram.
    any help would be great.

    many thanks.

    stephen.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    You have 3 radio antennas built into the back screen for different bands. Which band are you having problems with?
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    merlin4x4's Car Details
    Model of Car:
    320d es
    Year of Manufacture:
    2005
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    May 2011
    Location
    guisborough
    Posts
    9
    Thanks
    2
    Thanked 0 Times in 0 Posts
    hi. thanks for your reply. there are stations programed in to the radio. on fm if i press serch i dont get any thing . if i try one of the presets occasionaly as i drive down the road i must get a strong signal so i get some recption but it comes and gose havent tried mw. much but dont seem to get anything.

    stephen
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    Try the AM band and report back. Lock the frequency to a known station as well to see what happens.
     
     

  7.  
    #5
    Bimmer Fan
    Car Details
    merlin4x4's Car Details
    Model of Car:
    320d es
    Year of Manufacture:
    2005
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    May 2011
    Location
    guisborough
    Posts
    9
    Thanks
    2
    Thanked 0 Times in 0 Posts
    will try it in the morning and see what happens.

    thanks .
     
     

  8.  
    #6
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    Good...let's see if we can identify the problem is with your diversity amplifier or connections to it.
     
     

  9.  
    #7
    Bimmer Fan
    Car Details
    merlin4x4's Car Details
    Model of Car:
    320d es
    Year of Manufacture:
    2005
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    May 2011
    Location
    guisborough
    Posts
    9
    Thanks
    2
    Thanked 0 Times in 0 Posts
    hi.

    checked radio this morning it picked up some stations on am and mw but not alot and the recption wasent goood. on fm it did not find any at all except through the presetts and they where weak. looking through the history i got with the car it had a new rear window 5/1/2010 could this be a problem.

    cheers. stephen.
     
     

  10.  
    #8
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    New screen could be the problem. What you can do now is check the connections on the diversity amplifier. It sits behind the 3rd stop light and you can get access to it from the inside of the car.
     
     

  11.  
    #9
    Bimmer Fan
    Car Details
    merlin4x4's Car Details
    Model of Car:
    320d es
    Year of Manufacture:
    2005
    Transmission Type:
    manual
    Car Body Type:
    saloon

    Join Date
    May 2011
    Location
    guisborough
    Posts
    9
    Thanks
    2
    Thanked 0 Times in 0 Posts
    morning all.

    checked the connections on the diversity amplifier unpluged them all sprayed them with contact cleaner pluged them back in. still no joy everthing still the same. took head unit out checked conections on that tey seem ok. ???????????????
     
     

  12.  
    #10
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    Has the problem always been there or did start recently?
     
     

Page 1 of 2 12 LastLast
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts