2005 E60 525D airbag control unit fault!!

Notices
 

Thread: 2005 E60 525D airbag control unit fault!!

Reply to Thread
Results 1 to 4 of 4
  1. 2005 E60 525D airbag control unit fault!! 
    #1
    Bimmer Fan
    Car Details
    mancsfinest's Car Details
    Model of Car:
    525D
    Year of Manufacture:
    2005
    Transmission Type:
    Manual
    Car Body Type:
    Sallon

    Join Date
    Nov 2009
    Location
    UK
    Posts
    12
    Thanks
    5
    Thanked 0 Times in 0 Posts
    Hi all,
    I changed my cloth seats over to leather a while back & it triggered off the passenger airbag fault!! The pre tensioner had sprung on the passenger leather seat i bought so i used my pre tensioner from my original seat.
    There is a module under the seat(attached photo) which i didn't change. Would this still send an error to the main airbag unit even tho the pre tensioner is now ok??
    The lights been there ever since, which hadn't bothered me, but i now wish to sell my car
    I had somebody attempt to clear it using a Launch X431 and it gave an error 98DF control unit fault!! It cleared the error until you unplugged it and restarted the engine, then it reappears -
    I have now put the original module from my old seat on it. Do you think this will solve my problem??
    Any help appreciated
    Attached Images
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    Joe9087's Car Details
    Model of Car:
    E46 320ci M-Sport
    Year of Manufacture:
    2003
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    Joe9087's Avatar
    Join Date
    Feb 2009
    Location
    Ipswich
    Posts
    3,447
    Thanks
    1,262
    Thanked 2,701 Times in 2,156 Posts
    I've moved this to the Auto Electrical forum for you
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    olympia's Car Details
    Model of Car:
    530d
    Year of Manufacture:
    2005
    Transmission Type:
    auto
    Car Body Type:
    saloon

    Join Date
    Oct 2009
    Location
    coventry
    Posts
    6
    Thanks
    0
    Thanked 2 Times in 1 Post
    If you have put the original control unit back you should be able to just get the codes cleared using a diagnostic equipment
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Bimmer Fan
    Car Details
    mancsfinest's Car Details
    Model of Car:
    525D
    Year of Manufacture:
    2005
    Transmission Type:
    Manual
    Car Body Type:
    Sallon

    Join Date
    Nov 2009
    Location
    UK
    Posts
    12
    Thanks
    5
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by olympia View Post
    If you have put the original control unit back you should be able to just get the codes cleared using a diagnostic equipment
    Hi, thanks for the reply. So the picture i've posted is a control unit then?
    Regards
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts