2005 E46 320d - satnav locks up

Notices
 

Thread: 2005 E46 320d - satnav locks up

Reply to Thread
Results 1 to 5 of 5
  1. 2005 E46 320d - satnav locks up 
    #1
    Bimmer Fan
    Car Details
    Lost in Munich's Car Details
    Model of Car:
    320d
    Year of Manufacture:
    2005
    Transmission Type:
    Manual
    Car Body Type:
    Touring/Estate

    Join Date
    Jun 2009
    Location
    Munich, Germany
    Posts
    3
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Greetings from the BWM birthplace in Munich!

    My 2005 E46 320d sat nav works for a while then locks up (ie the screen freezes on the current display and stays in this state). This also leads to the other functions such as selecting the radio station failing.

    When the ignition is turned on and off, this sometimes fixes it for a while.

    I have also noticed that the sat nav get "confused" sometimes and gives an erroneous location and indicates a constantly changing direction.

    Any advice on how to fix this problem would be greatly appreciated!
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,398
    Thanks
    6,198
    Thanked 7,052 Times in 5,322 Posts
    What software/sat nav version are you running?
     
     

  4. The Following User Says Thank You to Ronnie For This Useful Post:

    Lost in Munich (26-06-2009)

  5.  
    #3
    Uber Platinum BFuk Member
    Car Details
    redadair's Car Details
    Model of Car:
    530d Sport (E60)
    Year of Manufacture:
    2005
    Transmission Type:
    Auto
    Car Body Type:
    Saloon
    redadair's Avatar
    Join Date
    Aug 2008
    Location
    Manchester
    Posts
    1,425
    Thanks
    372
    Thanked 334 Times in 286 Posts
    Loose or corroded sharkfin antenna perhaps or wherever it takes the GPS feed from....?

    CD / DVD in good nick? Red
     
     

  6. The Following User Says Thank You to redadair For This Useful Post:

    Lost in Munich (26-06-2009)

  7. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  8.  
    #4
    Bimmer Fan
    Car Details
    Lost in Munich's Car Details
    Model of Car:
    320d
    Year of Manufacture:
    2005
    Transmission Type:
    Manual
    Car Body Type:
    Touring/Estate

    Join Date
    Jun 2009
    Location
    Munich, Germany
    Posts
    3
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Hi Ronnie,

    Thanks for your reply. I went into the setup menu and it reported SW 4-1/80. Does that help?
     
     

  9.  
    #5
    Bimmer Fan
    Car Details
    Lost in Munich's Car Details
    Model of Car:
    320d
    Year of Manufacture:
    2005
    Transmission Type:
    Manual
    Car Body Type:
    Touring/Estate

    Join Date
    Jun 2009
    Location
    Munich, Germany
    Posts
    3
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Hi Red,

    Thanks for the suggestion, the car doesn't have has a sharkfin antenna so it must be located somewhere else. Anyway, I checked all the connections from the DVD and they seem and they seem OK.
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts