2004 E85 Z4 3.0i Alarm Keeps Going Off

Notices
 

Thread: 2004 E85 Z4 3.0i Alarm Keeps Going Off

Reply to Thread
Results 1 to 5 of 5
  1. 2004 E85 Z4 3.0i Alarm Keeps Going Off 
    #1
    BMW Crazed
    Car Details
    stolfordtone's Car Details
    Model of Car:
    Z4 3.0i SMG/523i
    Year of Manufacture:
    2004/2000
    Transmission Type:
    Semi-auto/Auto
    Car Body Type:
    Roadster/Touring
    stolfordtone's Avatar
    Join Date
    Nov 2008
    Location
    Somerset
    Posts
    106
    Thanks
    24
    Thanked 49 Times in 38 Posts
    I have an annoying problem with the Z4 and would welcome any ideas.

    When I leave the car & lock up, the alarm keeps going off randomly, sometimes after a few minutes, sometimes after an hour or so and once after about 6 or 7 hours! It's got to the stage that I now have to leave the car unlocked so as not to attract attention.

    I will be going to see the main dealer sometime this week to see if it records any specific faults, but before I do, I wondered if anyone else had had a similar problem or has any ideas.

    I'm hoping it's one of those things that can be re-set by pushing a few buttons etc.

    Thanks for any help you can give

    Cheers,
    Tone
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    Sounds like your interior sensors are playing up Tone. Switch them off and still alarm the rest of your car. To do this, press the lock button twice on the fob when arming the car...the clown nose will stay on for a couple of secs to acknowledge de-activation and then resume to blink as usual. If this works, then dealer will need to adjust sensitivity.
     
     

  4. The Following User Says Thank You to xXNealXx For This Useful Post:

    stolfordtone (26-04-2009)

  5.  
    #3
    BMW Crazed
    Car Details
    stolfordtone's Car Details
    Model of Car:
    Z4 3.0i SMG/523i
    Year of Manufacture:
    2004/2000
    Transmission Type:
    Semi-auto/Auto
    Car Body Type:
    Roadster/Touring
    stolfordtone's Avatar
    Join Date
    Nov 2008
    Location
    Somerset
    Posts
    106
    Thanks
    24
    Thanked 49 Times in 38 Posts
    Cheers Neal,

    Just set that...now I'll see how long it lasts.

    Fingers crossed.
     
     

  6. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  7.  
    #4
    BMW Crazed
    Car Details
    stolfordtone's Car Details
    Model of Car:
    Z4 3.0i SMG/523i
    Year of Manufacture:
    2004/2000
    Transmission Type:
    Semi-auto/Auto
    Car Body Type:
    Roadster/Touring
    stolfordtone's Avatar
    Join Date
    Nov 2008
    Location
    Somerset
    Posts
    106
    Thanks
    24
    Thanked 49 Times in 38 Posts
    Nice one Neal, problem sorted temporarily.

    I was able to rest easier last night knowing the car was secure.

    Thanks again
     
     

  8.  
    #5
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    No worries Tone...just need to get it sorted properly now
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts