2004 e60 bmw 530d i drive stopped working - HELP !!!!

Notices
 

Thread: 2004 e60 bmw 530d i drive stopped working - HELP !!!!

Reply to Thread
Results 1 to 7 of 7
  1. 2004 e60 bmw 530d i drive stopped working - HELP !!!! 
    #1
    Bimmer Fan
    Car Details
    aadam's Car Details
    Model of Car:
    530d
    Year of Manufacture:
    2003
    Transmission Type:
    auto
    Car Body Type:
    saloon

    Join Date
    Sep 2012
    Location
    birmingham
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    firstly would like to thank bimmer forums and all users for help on this site

    my pride and joy is driving me CRAZY!

    first my battery died twice in one day, needed a jup start to get started and
    now my i drive has stopped funtioning

    first time in the morning on the way to work i noticed no i drive then after 10 minutes of driving it just came on by itslef
    then after work driving home done the same took about 10 minutes to switch on
    next day no idrive just simplyy dont come on everything else works

    except : i drive - cd player - and i have a amplifier and subs fitted which are both not working , both amp and subs ?????????????

    check main fuses related to i drive and entertainment all good no blown fuses

    any one who can help

    iv read many threads sayin take to dealers but is there any check i can do my self or can it be anything minor which wont break the piggy bank ???????
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Maestro
    Car Details
    ragtop steve's Car Details
    Model of Car:
    E60 530D & F07 535D GT
    Year of Manufacture:
    2006 & 2012
    Transmission Type:
    manual & Auto
    Car Body Type:
    Saloon & Hatchback
    ragtop steve's Avatar
    Join Date
    Mar 2010
    Location
    Wiltshire
    Posts
    596
    Thanks
    9
    Thanked 150 Times in 129 Posts
    1st, if the battery has died twce then it's gona need replacng, you can check the top and see if its got a white spot on he top,,,if it has then its fubared. This may be the cause of your I-drve probles

    It may be that you need a sofwae upgrade, this can ONLY be done at a official BMW Dealer


    BMW its an addiction, Its a drug
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    aadam's Car Details
    Model of Car:
    530d
    Year of Manufacture:
    2003
    Transmission Type:
    auto
    Car Body Type:
    saloon

    Join Date
    Sep 2012
    Location
    birmingham
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts


    omg i hope this helps loads of bmw owners

    after doing loads of research i read loads of threads regarding boot floor flooding

    well i opened the boot and got started i took out all the boot carpets and found my boot had couple of inches of water and my i drive unit under water and my pdc parking sensor unit also in water so i disconnected both units and took them in and got out the misses hairdryer and got drying then got out my extention and took the dryer to the car boot and dryed out the plugs which connect to the unit then pluged back in and gave the wires a little pull and a push and WOW i look through the rear windscreen and my i drive screen is back up and running

    thanks for your help and hope this helps

    it will save you alot of money !!!!
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    BMW Maestro
    Car Details
    ragtop steve's Car Details
    Model of Car:
    E60 530D & F07 535D GT
    Year of Manufacture:
    2006 & 2012
    Transmission Type:
    manual & Auto
    Car Body Type:
    Saloon & Hatchback
    ragtop steve's Avatar
    Join Date
    Mar 2010
    Location
    Wiltshire
    Posts
    596
    Thanks
    9
    Thanked 150 Times in 129 Posts
    Thats great news,,,, will keep this in mind if i see it pop up again


    BMW its an addiction, Its a drug
     
     

  7. How to remove iDrive unit 
    #5
    Bimmer Fan
    Car Details
    dgtlittle's Car Details
    Model of Car:
    530D
    Year of Manufacture:
    2003
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon

    Join Date
    Nov 2012
    Location
    Reading
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I seem to have a similar problem...idrive started gong crazy, radio stations reset themselves, CD player kept turning on but now the whole screen has gone completely blank.

    Can you please tell me how did you remove the iDrive unit?

    Thanks!
     
     

  8. How to remove iDrive unit 
    #6
    Bimmer Fan
    Car Details
    dgtlittle's Car Details
    Model of Car:
    530D
    Year of Manufacture:
    2003
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon

    Join Date
    Nov 2012
    Location
    Reading
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I seem to have a similar problem...idrive started gong crazy, radio stations reset themselves, CD player kept turning on but now the whole screen has gone completely blank.

    Can you please tell me how did you remove the iDrive unit?

    Thanks!






    Quote Originally Posted by aadam View Post


    omg i hope this helps loads of bmw owners

    after doing loads of research i read loads of threads regarding boot floor flooding

    well i opened the boot and got started i took out all the boot carpets and found my boot had couple of inches of water and my i drive unit under water and my pdc parking sensor unit also in water so i disconnected both units and took them in and got out the misses hairdryer and got drying then got out my extention and took the dryer to the car boot and dryed out the plugs which connect to the unit then pluged back in and gave the wires a little pull and a push and WOW i look through the rear windscreen and my i drive screen is back up and running

    thanks for your help and hope this helps

    it will save you alot of money !!!!
     
     

  9.  
    #7
    Bimmer Fan
    Car Details
    aadam's Car Details
    Model of Car:
    530d
    Year of Manufacture:
    2003
    Transmission Type:
    auto
    Car Body Type:
    saloon

    Join Date
    Sep 2012
    Location
    birmingham
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    hello sorry to hear about the problems your having it can be fustrating

    i didnt need to remove the idrive as the i drive has a module in the bot under the spare tyre carpet
    remove all the carpet untill u see two modules under the carpet and look for water if ther is water remove water and open clean and dry module
    hopefully should start up straght away
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts