2004 E60 525i - Towbar Electrics Problem

Notices
 

Thread: 2004 E60 525i - Towbar Electrics Problem

Reply to Thread
Results 1 to 3 of 3
  1. 2004 E60 525i - Towbar Electrics Problem 
    #1
    Bimmer Fan
    Car Details
    silver toro's Car Details
    Model of Car:
    525i
    Year of Manufacture:
    2004
    Transmission Type:
    auotmatic
    Car Body Type:
    estate

    Join Date
    Sep 2009
    Location
    england
    Posts
    2
    Thanks
    0
    Thanked 1 Time in 1 Post
    Just installed a towbar which was really easy however the electrics are causing a problem.

    I am using a 7 way relay kit and have managed to wire up the indicators however the brake and side lights are a problem.

    I have identified two wires in the cars loom that activate the brake lights but the brake lights on the trailer stay on permanently.

    What are the colours in the cars loom for the side lights and brake lights ?

    How do you get around the issue that the trailer requires one wire for the sidelight and one for the brake light but on the car there only appears to be one wire for both?

    Many thanks
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Car Details
    silver toro's Car Details
    Model of Car:
    525i
    Year of Manufacture:
    2004
    Transmission Type:
    auotmatic
    Car Body Type:
    estate

    Join Date
    Sep 2009
    Location
    england
    Posts
    2
    Thanks
    0
    Thanked 1 Time in 1 Post
    For the record, I was testing the wires without them being plugged into the rear light cluster. Turns out the computer on the car therefore thought there was something wrong with the lights and hence why the brake lights on the trailer board did not work correctly. I plugged the wires back into the light cluster and all works fine now.

    If using a 7 way bypass relay, you only need to wire up the indicators, an earth and the red wire from the trailer board.
     
     

  4. The Following User Says Thank You to silver toro For This Useful Post:

    binman (25-09-2009)

  5.  
    #3
    BMW Fanatic
    Car Details
    taz2585's Car Details
    Model of Car:
    330 csi sport
    Year of Manufacture:
    2002
    Transmission Type:
    manual
    Car Body Type:
    coupe

    Join Date
    Oct 2008
    Location
    fife scotland
    Posts
    61
    Thanks
    4
    Thanked 3 Times in 3 Posts
    hi,had the same problem with my 2004 530d,the side lights are only 6v then when the brake is applied ups it to 12v,we had a nightmare wiring my towbar,but got it sorted out
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts