2004 E46 320D Touring engine management light

Notices
 

Thread: 2004 E46 320D Touring engine management light

Reply to Thread
Results 1 to 3 of 3
  1. 2004 E46 320D Touring engine management light 
    #1
    Bimmer Fan
    Car Details
    philc8888's Car Details
    Model of Car:
    320d touring
    Year of Manufacture:
    2008
    Transmission Type:
    manual
    Car Body Type:
    touring

    Join Date
    Nov 2009
    Location
    newark
    Posts
    18
    Thanks
    5
    Thanked 2 Times in 2 Posts
    Hi I have a intermitent problem with the EML staying on - letely has been on more than off.
    Have cleaned the EGR valve as detailed on the forum.
    Been coming on for quite a while and used to go off if I gave the car a long drive using high revs - doesn't seem to work now.
    Car now done 142,000 miles but still runs ok with the light on.
    I cover 27,000 miles a year and seldom do short trips - normally do 100 miles plus a day but find if drive for economy ie below 2,000 revs then light more prone to come on.

    Can anyone say what the problem is?
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    SlowTech's Car Details
    Model of Car:
    330ci
    Year of Manufacture:
    2003
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    SlowTech's Avatar
    Join Date
    Mar 2009
    Location
    North West
    Posts
    7,044
    Thanks
    3,720
    Thanked 3,799 Times in 3,107 Posts
    Far too many reasons to even try guessing, you need a diagnostic scan to reveal the cause.

    see this thread for further tips when you've had the scan http://www.bimmerforums.co.uk/forum/...nd-why-t47828/
     
     

  4.  
    #3
    Moderator
    Car Details
    matthew_henson's Car Details
    Model of Car:
    E61 525d Touring
    Year of Manufacture:
    2005
    Transmission Type:
    Manual
    Car Body Type:
    Touring/Estate
    matthew_henson's Avatar
    Join Date
    Mar 2011
    Location
    Forest Of Dean
    Posts
    4,210
    Thanks
    904
    Thanked 1,412 Times in 1,223 Posts
    Quote Originally Posted by SlowTech View Post
    Far too many reasons to even try guessing, you need a diagnostic scan to reveal the cause.

    see this thread for further tips when you've had the scan http://www.bimmerforums.co.uk/forum/...nd-why-t47828/
    I agree, but an easy thing to check are the vacuum hoses and all the plugs on all the sensors such as the MAF, MAP and the EGR pressure converter
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts