2004 E46 320D Touring - ABS sensor and other faults

Notices
 

Thread: 2004 E46 320D Touring - ABS sensor and other faults

Reply to Thread
Results 1 to 2 of 2
  1. 2004 E46 320D Touring - ABS sensor and other faults 
    #1
    Bimmer Fan
    Car Details
    sp_redeye's Car Details
    Model of Car:
    320d
    Year of Manufacture:
    2004
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Jan 2011
    Location
    Sussex
    Posts
    20
    Thanks
    0
    Thanked 1 Time in 1 Post
    Hi

    Few days ago lost speedo and all ABS and DSC lights came on. Quick search indicates the sensor, but the fault is intermittent.
    Scan with INPA reveals severl electrical errors all ocurred at same time.

    5DB1 Left Rear Wheel Speed Sensor : Extrapolation
    5DB3 Left Rear Wheel Speed Sensor : Accident Recognition

    112 seat occupancy
    wiring break seat mat
    Relay Rear window defogger
    short to ground

    190 lightmodule-eeprom
    invalid working earea
    131 speed A
    short circuit to ground


    Also error indicating the seat tensioners are giving too high a resitance reading.

    Spent weekend testing all circuits and looking at wiring, cleaned all connections to no avail.
    Wheel sensor seesm to measure OK.

    This morning no errors for 1st hour of driving then the lights came back on.
    Despite the seat occupancy and tensioner errors no Airbag light.

    Any ideas how I can tell whether the sensor is at fault or it is the reluctor ring corroded , or whetehr these errors could all be caused by a ground problem elsewhere.

    Steve
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3. faults 
    #2
    Bimmer Fan
    Car Details
    kev.f's Car Details
    Model of Car:
    520i
    Year of Manufacture:
    1998
    Transmission Type:
    automatic
    Car Body Type:
    touring

    Join Date
    Jun 2013
    Location
    church stretton
    Posts
    7
    Thanks
    1
    Thanked 0 Times in 0 Posts
    had same prob on e39,was faulty abs module,bought one off ebay 10 minute job and problem solved
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts