2004 530d touring, multiple failures in idrive

Notices
 

Thread: 2004 530d touring, multiple failures in idrive

Reply to Thread
Results 1 to 3 of 3
  1. 2004 530d touring, multiple failures in idrive 
    #1
    Bimmer Fan
    Car Details
    guy powis's Car Details
    Model of Car:
    530d touring
    Year of Manufacture:
    2004
    Transmission Type:
    auto
    Car Body Type:
    touring

    Join Date
    May 2012
    Location
    suffolk
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi,
    Can anyone help?
    Ive had the car 3 years and its been superb, covered 113k and still like new. had new compressor for rear suspension 6 months ago and has just started with this multiple failures on idrive inc, servotronic,battery,seatbelt, ABS.
    after reading some posts on here all pointed towards a new battery, mine had a dead cell and was the original, so i replaced it like for like. My mechanic has the Snap on gadget that plugs in, we registered the new battery in power management menu.
    Next day dash lights up again power steering fails, i get it to the mechanic but he cant find the problem other than relay 1 failure in power management menu???
    Anyone know what this is? do I have to bite the bullet a go to dealer?
    any help would be great, as you can tell I only drive the thing and dont know how it works!
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Maestro
    Car Details
    mjojom's Car Details
    Model of Car:
    e61
    Year of Manufacture:
    2004
    Transmission Type:
    A
    Car Body Type:
    T

    Join Date
    Jul 2011
    Location
    UK
    Posts
    713
    Thanks
    240
    Thanked 201 Times in 164 Posts
    check the battery again with volt meter after you get all this errors. this again seems like alternator intermittent charging. same posts here mostly lead to the alternator issue.
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    guy powis's Car Details
    Model of Car:
    530d touring
    Year of Manufacture:
    2004
    Transmission Type:
    auto
    Car Body Type:
    touring

    Join Date
    May 2012
    Location
    suffolk
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    We checked the alternator output while all the faults were showing,and it was 15v?
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts