2003 E46 318i - PDC Rear Sensor Fault?

Notices
 

Thread: 2003 E46 318i - PDC Rear Sensor Fault?

Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 20
  1. 2003 E46 318i - PDC Rear Sensor Fault? 
    #1
    BMW Master
    Car Details
    kevz65's Car Details
    Model of Car:
    330i E92
    Year of Manufacture:
    2008
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    kevz65's Avatar
    Join Date
    Feb 2009
    Location
    London
    Posts
    358
    Thanks
    34
    Thanked 28 Times in 26 Posts
    Hey guys.

    I just washed the car today, and before this my rear PDC was working fine...After washing it seems to be working weirdly, when in reverse i get a series of long beeps and then nothing(if there is no car behind). Is there something wrong? Could water have got in to sensors?( i was using hose pipe to wash..)
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    You just need to let it dry out Kev. Water may have got into it.
     
     

  4.  
    #3
    BMW Master
    Car Details
    kevz65's Car Details
    Model of Car:
    330i E92
    Year of Manufacture:
    2008
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    kevz65's Avatar
    Join Date
    Feb 2009
    Location
    London
    Posts
    358
    Thanks
    34
    Thanked 28 Times in 26 Posts
    Quote Originally Posted by NealP View Post
    You just need to let it dry out Kev. Water may have got into it.
    I'll check it later matey.

     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    BMW Master
    Car Details
    kevz65's Car Details
    Model of Car:
    330i E92
    Year of Manufacture:
    2008
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    kevz65's Avatar
    Join Date
    Feb 2009
    Location
    London
    Posts
    358
    Thanks
    34
    Thanked 28 Times in 26 Posts
    Neal, The sensors don't work at all now! No beeping at all :(...
     
     

  7.  
    #5
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    You must have read on the forum how to test each sensor by listening for the click noise, right?
     
     

  8.  
    #6
    BMW Master
    Car Details
    kevz65's Car Details
    Model of Car:
    330i E92
    Year of Manufacture:
    2008
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    kevz65's Avatar
    Join Date
    Feb 2009
    Location
    London
    Posts
    358
    Thanks
    34
    Thanked 28 Times in 26 Posts
    Hey I just tested the sensors. Three out of four making the clicking sound and on one its very faint or nonexistent. What can I do?
     
     

  9.  
    #7
    BMW Crazed
    Car Details
    clearhope's Car Details
    Model of Car:
    e46
    Year of Manufacture:
    2001
    Transmission Type:
    auto
    Car Body Type:
    saloon
    clearhope's Avatar
    Join Date
    May 2009
    Location
    plymouth
    Posts
    128
    Thanks
    11
    Thanked 8 Times in 7 Posts
    i had the same happen to me, washed the car and then the same problem as you have, i too was told to let the car dry out, the next day the sensors worked yipee, but then they started to play up again , i listenend to the sensors and 1 of them wasnt clicking, i now need to replace this , why should washing a bmw
    CAUSE SUCH A PROBLEM EH ? Next time im buying a skoda

    good luck , try letting them dry out for a day or two
     
     

  10.  
    #8
    BMW Fanatic
    Car Details
    honest_al's Car Details
    Model of Car:
    318ci
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    honest_al's Avatar
    Join Date
    Apr 2009
    Location
    Manchester, U.K.
    Posts
    55
    Thanks
    15
    Thanked 8 Times in 5 Posts
    i just bought one off flea bay tonight, as one of mine was faulty.

    in fact, mine has been faulty for last 3 years lol, just never got round to fixing it.
     
     

  11.  
    #9
    BMW Master
    Car Details
    kevz65's Car Details
    Model of Car:
    330i E92
    Year of Manufacture:
    2008
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    kevz65's Avatar
    Join Date
    Feb 2009
    Location
    London
    Posts
    358
    Thanks
    34
    Thanked 28 Times in 26 Posts
    Quote Originally Posted by honest_al View Post
    i just bought one off flea bay tonight, as one of mine was faulty.

    in fact, mine has been faulty for last 3 years lol, just never got round to fixing it.
    How much it set you back? I've looked on ebay but can't see anything
     
     

  12.  
    #10
    BMW Crazed
    Car Details
    stolfordtone's Car Details
    Model of Car:
    Z4 3.0i SMG/523i
    Year of Manufacture:
    2004/2000
    Transmission Type:
    Semi-auto/Auto
    Car Body Type:
    Roadster/Touring
    stolfordtone's Avatar
    Join Date
    Nov 2008
    Location
    Somerset
    Posts
    106
    Thanks
    24
    Thanked 49 Times in 38 Posts
    Quote Originally Posted by kevz65 View Post
    How much it set you back? I've looked on ebay but can't see anything
    I'd be quite interested too as I've just bought one today from the main dealer at £65 plus VAT

    Second one I've had to replace
     
     

Page 1 of 2 12 LastLast

LinkBacks (?)


Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts