2003 e46 318ci weird electric problem

Notices
 

Thread: 2003 e46 318ci weird electric problem

Reply to Thread
Results 1 to 3 of 3
  1. 2003 e46 318ci weird electric problem 
    #1
    Bimmer Fan
    Car Details
    dazza87's Car Details
    Model of Car:
    318ci Sport
    Year of Manufacture:
    2003
    Transmission Type:
    Manual
    Car Body Type:
    Convertable

    Join Date
    Apr 2011
    Location
    northampton
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    welcome guys & girls, im wondering if anyone can help me on my problem

    Basically i have a 2003 318ci sport convertable, with a strange but annoying problems. When i drive the airbag warning light appears and the indicators begin to play up; i signal left, the indicators work but the intrument panel doesnt blink, then it begins to work, also sometimes when i switch the indicator off it carries on, not only that when listening to a cd its switches automatically over to the radio, all these seem to happen at the same time? then fix themselves randomly, the only way that seems to get the car acting normal is to pull to a standstill, wait for it to fix its self then drive on, but 5 minsutes later it begins again.

    This all seemed to happen the other day after suffering a flat battery, i jump started the car (but direct from the battery apparently your not meant to do this?)

    All other functions of the car seems fine, lights, steering wheel controls, aircon, roof up & down ect...

    Hopefully someone can point me in the right direction as this car is becoming a pain in the rear, especially after last months oil, steering fluid & coolant leaks

    thanks
    Darren
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Crazed
    Car Details
    colin.ab's Car Details
    Model of Car:
    530d
    Year of Manufacture:
    2002
    Transmission Type:
    Auto
    Car Body Type:
    Touring

    Join Date
    Dec 2009
    Location
    Berkshire
    Posts
    248
    Thanks
    8
    Thanked 49 Times in 45 Posts
    Sounds like a common fault with k-bus data signal corruption. This is ususally caused by one k-bus unit causing a fault.

    PM if you would like help with it.
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    dazza87's Car Details
    Model of Car:
    318ci Sport
    Year of Manufacture:
    2003
    Transmission Type:
    Manual
    Car Body Type:
    Convertable

    Join Date
    Apr 2011
    Location
    northampton
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    i seem to have located the problem, on the wiring harness which attaches to the cd multi changer, there is an earth wire which goes to a grounding point. Upon closer inspection the little spade connections had become corroded, i cleaned it all up and put new spade connections on it, and to my relieve all problems have been sorted. Thanks for all your help
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts