2002 E46 330i - Fuel level not updating?

Notices
 

Thread: 2002 E46 330i - Fuel level not updating?

Reply to Thread
Results 1 to 7 of 7
  1. 2002 E46 330i - Fuel level not updating? 
    #1
    Bimmer Fan
    Car Details
    Christoff330's Car Details
    Model of Car:
    330i
    Year of Manufacture:
    2002
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Jan 2010
    Location
    York
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hello all, wondering if you can help.. have a problem and not sure where to start looking!

    I've had a problem with the fuel gauge since I bought the car, whenever I go to the petrol station to refill, the fuel level on the fuel gauge doesn't update. What I have to do is essentially restart the instrument cluster by removing the fuse and replacing it, this seems to clear its memory and update my fuel level. However, in the meantime deleting all my clock settings, average speed, tripmeters.

    I knew I had a dodgy sender on the fuel pump, have just replaced the pump and sender on the drivers side. This hasnt cured the problem, does anyone know if this will be an electronics problem, ie communication between the dash and the fuel sender or an instrument cluster problem?

    I'm mystified! Hope you can help

    My car, by the way, is a 2002 330 saloon. 68000 miles.

    Thanks

    Chris
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    328mark's Car Details
    Model of Car:
    E46 328i se
    Year of Manufacture:
    1998
    Transmission Type:
    manual
    Car Body Type:
    saloon
    328mark's Avatar
    Join Date
    Aug 2008
    Location
    corringham essex
    Posts
    5,471
    Thanks
    815
    Thanked 2,426 Times in 1,920 Posts
    the guage doesnt go up but does the cars range on the computer update?
    what i've felt,what i've known
    never shined through in what i've shown.

    -------------------------------------------
    PLEASE READ THE POSTING RULES & HOW TO CORRECT THREAD TITLES & THE SELLING RULES
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    Christoff330's Car Details
    Model of Car:
    330i
    Year of Manufacture:
    2002
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Jan 2010
    Location
    York
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Nothing changes until I reset the instrument cluster. Miles per gallon, fuel range and gauge all seem to be linked? :(
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Bimmer Fan
    Car Details
    Christoff330's Car Details
    Model of Car:
    330i
    Year of Manufacture:
    2002
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Jan 2010
    Location
    York
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Any ideas? :( Really no idea where to look.... electrics are complete greek to me :(
     
     

  7.  
    #5
    BMW Master
    Car Details
    luke1925's Car Details
    Model of Car:
    323ci
    Year of Manufacture:
    1999
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    luke1925's Avatar
    Join Date
    Apr 2009
    Location
    Brentford
    Posts
    354
    Thanks
    4
    Thanked 48 Times in 44 Posts
    could be fuel level sensor, that would be the first thing to check
     
     

  8.  
    #6
    BMW Guru
    Car Details
    328mark's Car Details
    Model of Car:
    E46 328i se
    Year of Manufacture:
    1998
    Transmission Type:
    manual
    Car Body Type:
    saloon
    328mark's Avatar
    Join Date
    Aug 2008
    Location
    corringham essex
    Posts
    5,471
    Thanks
    815
    Thanked 2,426 Times in 1,920 Posts
    electrics arent my strong point either...will move this to the electrical forum in the hope someone there can help
    what i've felt,what i've known
    never shined through in what i've shown.

    -------------------------------------------
    PLEASE READ THE POSTING RULES & HOW TO CORRECT THREAD TITLES & THE SELLING RULES
     
     

  9.  
    #7
    Bimmer Fan
    Car Details
    Christoff330's Car Details
    Model of Car:
    330i
    Year of Manufacture:
    2002
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Jan 2010
    Location
    York
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks

    Quote Originally Posted by luke1925 View Post
    could be fuel level sensor, that would be the first thing to check
    Have replaced the drivers side sensor, the one integrated with the pump, I'd assume this was a master sensor of sorts? Reckon its worth replacing passenger side as well?

    Just seems strange that the dash sees the right fuel level, just not until I've reset the instrument cluster?
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts