2002 E46 330ci - Warning Lights - Traction Control & Brakes, codes, what do they mean?

Notices
 

Thread: 2002 E46 330ci - Warning Lights - Traction Control & Brakes, codes, what do they mean?

Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. 2002 E46 330ci - Warning Lights - Traction Control & Brakes, codes, what do they mean? 
    #1
    Bimmer Fan
    Car Details
    Phil1067's Car Details
    Model of Car:
    330ci Clubsport
    Year of Manufacture:
    2002
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe

    Join Date
    May 2009
    Location
    N.Ireland
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Hi,

    I was Driving home last night and both the traction control light and the brake light came on and stayed on, the brake light is amber not red!
    Does anyone have any ideas what could be the cause of this before i get the codes read...??

    I have tried turning the traction control on and off using the DSC button and this makes no difference....!!
    She's an Automatic if that makes any difference!
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    You will need to get the diagnostic codes read for you ABS system. Most likely a faulty rear wheel speed sensor, but the codes will confirm.
     
     

  4. The Following User Says Thank You to xXNealXx For This Useful Post:

    Phil1067 (11-08-2009)

  5.  
    #3
    BMW Guru
    Car Details
    Deano16v's Car Details
    Model of Car:
    745i
    Year of Manufacture:
    2003
    Transmission Type:
    Auto
    Car Body Type:
    Saloon

    Join Date
    Sep 2008
    Location
    Kent
    Posts
    3,632
    Thanks
    652
    Thanked 1,154 Times in 1,001 Posts
    wheel speed sensor i bet as well
     
     

  6. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  7.  
    #4
    BMW Crazed
    Car Details
    Ronaldo's Car Details
    Model of Car:
    e46 318Ci
    Year of Manufacture:
    2006
    Transmission Type:
    Manual Transmission
    Car Body Type:
    Convertible

    Join Date
    Dec 2008
    Location
    London
    Posts
    227
    Thanks
    16
    Thanked 23 Times in 23 Posts
    any update on what it is? i got same problem but code said right abs sensor "fault or no signal"
     
     

  8.  
    #5
    Bimmer Fan
    Car Details
    Beemeyboy's Car Details
    Model of Car:
    330Cd/323Ia/325Tds
    Year of Manufacture:
    2004/1998/1993
    Transmission Type:
    Auto x3
    Car Body Type:
    Coupe/Cabrio/Saloon

    Join Date
    Dec 2008
    Location
    Winchester
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I've got a 2004 330 Cd M-sport with same two warning lights illuminated. Just working it through. Fault codes showed front speed sensors & pressure switches No.1 & 2. Have replaced both wheel sensors & voided codes. OK for a week...then lights back on! Codes show Pressure switch 1 & 2...but only "2" can be cleared. Therefore, reluctantly I will change No.1 Switch tomorrow, which involves another £80 for each switch & full brake fluid bleed. Hope this works??
    Could also consider this thread... "2002 E46 325ti - Codes read... What do they mean???" which I found on a second search for inspiration!
    Last edited by Beemeyboy; 13-08-2009 at 22:26. Reason: A second search for inspiration!
     
     

  9.  
    #6
    Dr of BMW
    Car Details
    Diablo944's Car Details
    Model of Car:
    325 ti compact sport
    Year of Manufacture:
    2002
    Transmission Type:
    leadfoot sport trip
    Car Body Type:
    compact
    Diablo944's Avatar
    Join Date
    Mar 2009
    Location
    uk
    Posts
    1,034
    Thanks
    70
    Thanked 381 Times in 296 Posts
    This might seem a bit silly, but deserves a mention just in case. Is your battery fully charged? I had a flat battery last week. When I got enough charge in to start the car it left me with those same fault lights. They cleared themselves later in the day as the car was being driven. But I mention it solely in case its the million to one shot that your battery is in the same borderline state mine was in, where the car will start but the power available isnt enough for the sensors involved to be happy.

    I doubt it is your problem, but it would be wrong of me to not say anything if you spend a fortune in trying to correct your issues and then find its the same problem I had.
    2002 325 Compact Sport ti M-Tec---- A little thanks goes a long way
     
     

  10.  
    #7
    Bimmer Fan
    Car Details
    Phil1067's Car Details
    Model of Car:
    330ci Clubsport
    Year of Manufacture:
    2002
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe

    Join Date
    May 2009
    Location
    N.Ireland
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Haven't had a chance to get it looked at yet, will probably be another 2weeks before I do.
    I spoke to a BMW specialist and he agreed that I need to get the codes read but said its still fine to drive as long as I take it easy as I probably dont have any traction control.

    I'll post more information when i get it sorted

    Thanks for all your posts....!!
     
     

  11.  
    #8
    Bimmer Fan
    Car Details
    Phil1067's Car Details
    Model of Car:
    330ci Clubsport
    Year of Manufacture:
    2002
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe

    Join Date
    May 2009
    Location
    N.Ireland
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Ok....so i was driving home at the weekend and both the warning lights went out, they came one once again for a couple of minutes but have since gone out.

    Must be a dodgy connection somewhere, hopefully they'll stay out

    Sorry i can't offer any more useful information on how to solve this problem
     
     

  12.  
    #9
    doz
    doz is offline
    Bimmer Fan
    Car Details
    doz's Car Details
    Model of Car:
    330d M Sport
    Year of Manufacture:
    2007
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Aug 2009
    Location
    herts
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Its more than likely a sensor fault, does the speedo still work when the lights come on??

    Probably N/S/R sensor fault
     
     

  13.  
    #10
    Bimmer Fan
    Car Details
    Beemeyboy's Car Details
    Model of Car:
    330Cd/323Ia/325Tds
    Year of Manufacture:
    2004/1998/1993
    Transmission Type:
    Auto x3
    Car Body Type:
    Coupe/Cabrio/Saloon

    Join Date
    Dec 2008
    Location
    Winchester
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    JSUK. To confirm for others experiencing these problems that the diagnostic was correct for my case. Replaced both sensors 1&2 (due to work-up in accessing them!!) Now done 2000 mls fault-free. PS- You will need to pressure-bleed the braking system after this exercise to achieve a "good" pedal.
     
     

Page 1 of 2 12 LastLast
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts