2002 e46 320Ci - fog light illuminates when pressing brake pedal

Notices
 

Thread: 2002 e46 320Ci - fog light illuminates when pressing brake pedal

Reply to Thread
Results 1 to 10 of 10
  1. 2002 e46 320Ci - fog light illuminates when pressing brake pedal 
    #1
    Bimmer Fan
    Car Details
    jamesh7142's Car Details
    Model of Car:
    320ci se
    Year of Manufacture:
    2002
    Transmission Type:
    manual
    Car Body Type:
    coupe

    Join Date
    Jan 2011
    Location
    wales
    Posts
    5
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Hi all im new to this forum and hoping someone can shed some advice on a problem i have on my e46 320ci coupe.
    Yesterday the both rear light warning lamps illuminated on my dash. I thought this would be just a blown bulb so had a friend check my tail lights while i pressed the brake pedal. All four brake lights are working fine and the one in rear window, but the fog light in the bootlid is illuminating too, which must be whats causing the brake light fault in dash. I have read the common earth problems on here and have removed both rear light clusters and checked the pins inside the black connectors but there is no burnt out pins or any corrosion. The only thing i have noticed is that the brown earth wire going into the plug feels quite hard, so wonder whether this may actually be the prob? Also i have changed all 4 brake light bulbs this morning, which has made no difference at all.
    Im thinking of trying to cut the brown earth wire back and doing the earth mod shown on here.
    has anyone had this prob with the fog light coming on with the brake lights before?
    Also the fog light works perfectly on its own with the switch on the dash, which is why im thinking that it could well be the brown earth wire to the rear cluster causing this to short circuit a nd light the fog light.
    Can anyone tell me exactly where i need to fix the earth wire to on my rear cluster board as the pics on here look a different cluster to mine, it has a six pin single line rather than an 8pin double line connector, a pic would be a great help!

    Thanks in advance for any info, any advice would be very much apprreciated!
    Last edited by mark@vorny.co.uk; 27-01-2011 at 16:40. Reason: Please familiarise yourself with forum rules ref thread titles
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Master
    Car Details
    d9n_dk's Car Details
    Model of Car:
    535
    Year of Manufacture:
    2002
    Transmission Type:
    automatic
    Car Body Type:
    saloon
    d9n_dk's Avatar
    Join Date
    Jul 2010
    Location
    Bromley
    Posts
    412
    Thanks
    362
    Thanked 262 Times in 195 Posts
    to me mate it sounds like you have a earth trouble somewhere if it was me i would check the earth first by stripping back the earth wire (in your case brown i think ) attach a bit of wire to it and the other end of that wire put it on a metal spot that is in contact with the body (only do this if you know the brown cable is earth)i.e a boot catch and then while holding it get a mate to press the brake to see if this helps it if so then yes you have an earth problem and you can go from there
     
     

  4. The Following User Says Thank You to d9n_dk For This Useful Post:

    jamesh7142 (27-01-2011)

  5.  
    #3
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,398
    Thanks
    6,198
    Thanked 7,052 Times in 5,322 Posts
    Check the wiring at boot hinge, the insulation cracks and shorts out wires, common issue.
     
     

  6. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  7.  
    #4
    Bimmer Fan
    Car Details
    jamesh7142's Car Details
    Model of Car:
    320ci se
    Year of Manufacture:
    2002
    Transmission Type:
    manual
    Car Body Type:
    coupe

    Join Date
    Jan 2011
    Location
    wales
    Posts
    5
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thanks for the info both, the boot hinge wiring is covered in a rubber boot which has no damage but will peel it back in the morn and have a look first before trying the earth remedy.
     
     

  8.  
    #5
    Bimmer Fan
    Car Details
    jamesh7142's Car Details
    Model of Car:
    320ci se
    Year of Manufacture:
    2002
    Transmission Type:
    manual
    Car Body Type:
    coupe

    Join Date
    Jan 2011
    Location
    wales
    Posts
    5
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I have now checked the boot hinge wire and it looks fine, have also stripped the brown wire to the rear clusters and tried the new earth, and still have the fog light illuminating with the brake lights! Any ideas where to look next on this guys? ive taken the fog light bulb out for now and only have the rear offside warning light on the dash(fog light side) showing, whereas the both rear light warning lights were showing before. Im stumped
     
     

  9.  
    #6
    BMW Master
    Car Details
    d9n_dk's Car Details
    Model of Car:
    535
    Year of Manufacture:
    2002
    Transmission Type:
    automatic
    Car Body Type:
    saloon
    d9n_dk's Avatar
    Join Date
    Jul 2010
    Location
    Bromley
    Posts
    412
    Thanks
    362
    Thanked 262 Times in 195 Posts
    im just trying to think of what clusters you have do you have 2 fog lights either side or just 1 if u have 2 how about swap the bulbs over left to right and right to left does the warning on the dash change with it?
     
     

  10.  
    #7
    BMW Fanatic
    Car Details
    WeeChris_1990's Car Details
    Model of Car:
    535d M sport
    Year of Manufacture:
    2006
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon

    Join Date
    Sep 2010
    Location
    Bathgate
    Posts
    32
    Images
    1
    Thanks
    0
    Thanked 1 Time in 1 Post
    Make sure the bulbs are in correctly mate.. Ive had trouble with cars in the past, and if a bulb is even in upside down it can trip all elelctrics and lighting in the car!
     
     

  11.  
    #8
    BMW Master
    Car Details
    d9n_dk's Car Details
    Model of Car:
    535
    Year of Manufacture:
    2002
    Transmission Type:
    automatic
    Car Body Type:
    saloon
    d9n_dk's Avatar
    Join Date
    Jul 2010
    Location
    Bromley
    Posts
    412
    Thanks
    362
    Thanked 262 Times in 195 Posts
    Quote Originally Posted by WeeChris_1990 View Post
    Make sure the bulbs are in correctly mate.. Ive had trouble with cars in the past, and if a bulb is even in upside down it can trip all elelctrics and lighting in the car!
    that is also very true
     
     

  12.  
    #9
    Bimmer Fan
    Car Details
    jamesh7142's Car Details
    Model of Car:
    320ci se
    Year of Manufacture:
    2002
    Transmission Type:
    manual
    Car Body Type:
    coupe

    Join Date
    Jan 2011
    Location
    wales
    Posts
    5
    Thanks
    1
    Thanked 0 Times in 0 Posts
    after a week without the fog light bulb in, i replaced it on thursday to have another look and would u believe it, it hasnt happened since! typical.
     
     

  13.  
    #10
    BMW Master
    Car Details
    d9n_dk's Car Details
    Model of Car:
    535
    Year of Manufacture:
    2002
    Transmission Type:
    automatic
    Car Body Type:
    saloon
    d9n_dk's Avatar
    Join Date
    Jul 2010
    Location
    Bromley
    Posts
    412
    Thanks
    362
    Thanked 262 Times in 195 Posts
    glad to hear it just keep an eye on it and see how it goes
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts