2002 E46 318i - stalling when driving and jumping

Notices
 

Thread: 2002 E46 318i - stalling when driving and jumping

Reply to Thread
Results 1 to 8 of 8
  1. 2002 E46 318i - stalling when driving and jumping 
    #1
    Bimmer Fan
    Car Details
    beemer2009's Car Details
    Model of Car:
    318i
    Year of Manufacture:
    2002
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Aug 2009
    Location
    North East UK
    Posts
    4
    Thanks
    0
    Thanked 2 Times in 1 Post
    Hi folks,

    Just joined today so hope you can help.

    I have owned a 2002 E46 318 which was stalling when driving and jumping. My local garage advised a new alternator should fix the problem, however, this has continued and has actually got worse. The car is now stalling when driving and did so today at 70mph!

    Ive taken it back to the garage and they have said they can't find any faults on the computer and it hasnt happened for them. generally it seems to occur when driving and once the engine is warm.

    Any ideas? Im pulling whats left of my hair out over this!!!
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    Perhaps a similar problem to yours? http://www.bimmerforums.co.uk/forum/...riving-t17197/
     
     

  4.  
    #3
    BFuk Moderator
    Car Details
    Martyn D.'s Car Details
    Model of Car:
    330 ci
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    coupe
    Martyn D.'s Avatar
    Join Date
    May 2009
    Location
    Cambridgeshire
    Posts
    2,681
    Thanks
    2,478
    Thanked 3,484 Times in 2,111 Posts
    Is the garage a BMW specialist? Could be a few things eg maf sensor fault won't always show up as an error code, also check for no split hoses letting air in
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Bimmer Fan
    Car Details
    beemer2009's Car Details
    Model of Car:
    318i
    Year of Manufacture:
    2002
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Aug 2009
    Location
    North East UK
    Posts
    4
    Thanks
    0
    Thanked 2 Times in 1 Post
    Just read that too...however, my car isnt returning any fault codes which is why both garages have been stumped.

    No its an independent garage
     
     

  7.  
    #5
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    On some occasions, a problem cam sensor will not return a fault. Also, check for air leaks in the vacuum pipes as Martyn mentions above.
     
     

  8.  
    #6
    Bimmer Fan
    Car Details
    beemer2009's Car Details
    Model of Car:
    318i
    Year of Manufacture:
    2002
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Aug 2009
    Location
    North East UK
    Posts
    4
    Thanks
    0
    Thanked 2 Times in 1 Post
    Thanks folks for the quick replies.

    Im going to give the garage a buzz and see what they say
     
     

  9.  
    #7
    Bimmer Fan
    Car Details
    beemer2009's Car Details
    Model of Car:
    318i
    Year of Manufacture:
    2002
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Aug 2009
    Location
    North East UK
    Posts
    4
    Thanks
    0
    Thanked 2 Times in 1 Post
    Quick update - the garage have diagnosed a crank sensor problem so are going to sort this.

    Will keep you posted
     
     

  10. The Following 2 Users Say Thank You to beemer2009 For This Useful Post:

    bitbot (06-08-2009),steve23002 (04-08-2009)

  11. E46 cutting out 
    #8
    Bimmer Fan
    Car Details
    bitbot's Car Details
    Model of Car:
    316ti
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    hatchback

    Join Date
    Aug 2009
    Location
    kent
    Posts
    1
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Got an E46 316ti 2001, cuts out and stalls. Seems to be a common problem. Going to try changing cam sensor.
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts