2002 E46 316ti compact, washer sensor and temp sensor not working

Notices
 

Thread: 2002 E46 316ti compact, washer sensor and temp sensor not working

Reply to Thread
Results 1 to 3 of 3
  1. 2002 E46 316ti compact, washer sensor and temp sensor not working 
    #1
    Bimmer Fan
    Car Details
    drvarney's Car Details
    Model of Car:
    316ti
    Year of Manufacture:
    2002
    Transmission Type:
    Manual
    Car Body Type:
    Compact

    Join Date
    Aug 2009
    Location
    Norn Irn
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hey everyone.

    Cheers for the great resource...I've benefitted from the collective wisdom on the forum.

    My windscreen washer light on the dash is always on, and my temperature is always -40 on the OBC. Fine, so I replaced both the temp sensor and the windscreen washer sensor (after removing the whole washer unit and giving it a darn good clean out - full of gunk).

    But, neither has done any different. I ran a diagnostic myself which confirms ambient temperature error (obviously) and something about CAN-BUS run gear control not working.

    Are these things linked or have I just bought two (new) dodgy sensors?

    Cheers in advance
    Dave
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,394
    Thanks
    6,198
    Thanked 7,051 Times in 5,322 Posts
    Where did you get the sensors from? main dealer?
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    drvarney's Car Details
    Model of Car:
    316ti
    Year of Manufacture:
    2002
    Transmission Type:
    Manual
    Car Body Type:
    Compact

    Join Date
    Aug 2009
    Location
    Norn Irn
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    No Ronnie, I got a cheapo temperature sensor from ebay in an effort to save some ££ and the water bottle sensor came from the USA from a BMW parts place...turns out it was Made in Taiwan.

    Think that could be the problem? Money saving schemes backfired on me?

    Cheers,
    dave
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts