2002 E46 316ti Compact - electical issue

Notices
 

Thread: 2002 E46 316ti Compact - electical issue

Reply to Thread
Results 1 to 2 of 2
  1. 2002 E46 316ti Compact - electical issue 
    #1
    Bimmer Fan
    Car Details
    matty6678's Car Details
    Model of Car:
    316ti
    Year of Manufacture:
    2002
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Jan 2011
    Location
    UK
    Posts
    2
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Hi,

    I have a problem with the car starting.

    The +ve junction in the engine compartment is getting hot and the contacts have become very corroded. The battery is going flat over night which would suggest some sort of shot

    1st question is is the corrosion / poor contact on the leads going to be causing the heat.

    If not anyone got any suggestions as to what to try.

    Thanks in advance.

    Matt
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Platinum BFuk Member
    Car Details
    sam1832's Car Details
    Model of Car:
    318ci
    Year of Manufacture:
    2004
    Transmission Type:
    manual
    Car Body Type:
    convertable Msport
    sam1832's Avatar
    Join Date
    May 2010
    Location
    essex
    Posts
    2,578
    Thanks
    407
    Thanked 811 Times in 675 Posts
    if they are badly corroded, like most electrical connections this will cause a high resistant joint and will get hot,

    you can clean it up your self, take it apart and use like a brill pad with a bit of wd-40 sprayed on it and rub at the corrasion to clean it off

    put it all back together,

    Has the connection been touching any body work? bonnet?
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts