2001 E46 330d Instrument Cluster Dead.

Notices
 

Thread: 2001 E46 330d Instrument Cluster Dead.

Reply to Thread
Results 1 to 5 of 5
  1. 2001 E46 330d Instrument Cluster Dead. 
    #1
    Bimmer Fan
    Car Details
    wotzvoltz's Car Details
    Model of Car:
    330d
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Jan 2010
    Location
    cardiff
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hello Everyone, Sorry this is my first post and I have not even introduced myself, but I could really do with a little help.

    I have had a starting problem, where the engine was cranking but not firing, which, as they do cleared itself, for no apparent reason. Now the car starts but my instrument cluster is dead, it lights up, but no speedo, rev counter, engine temperature, or on board computer.

    When I turn the key to start, I only get seat belt/airbag warning light, abs warning light, and handbrake light come on and off. I am missing everything else except fuel gauge which is working fine. The car starts and runs as normal.

    I have done the basics fuses etc. and am now stumped.
    Any input greatly appreciated.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    RYM
    RYM is offline
    Legendary BFuk Member
    Car Details
    RYM's Car Details
    Model of Car:
    325tds
    Year of Manufacture:
    1996
    Transmission Type:
    Manual
    Car Body Type:
    Touring
    RYM's Avatar
    Join Date
    Apr 2008
    Location
    Bristol
    Posts
    12,959
    Thanks
    5,540
    Thanked 4,935 Times in 3,119 Posts
     
     

  4. Good for a laugh. 
    #3
    Bimmer Fan
    Car Details
    wotzvoltz's Car Details
    Model of Car:
    330d
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Jan 2010
    Location
    cardiff
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Forgot to add, Whilst at work I disconnected the battery for a couple of hours in the hope of switching off and on again would re-set the bus, It didn't.

    But in my haste to come home, forgot to put the battery cover back. 1 mile down the road, a beautiful smell of burning, then something else awful smelling from my seat! as flames started shooting from the boot.

    A can of window defroster had shorted the terminal and started spitting flame jets from the pierced can. One fire extinguisher later, on my way again with only minor singeing!

    What next
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Bimmer Fan
    Car Details
    wotzvoltz's Car Details
    Model of Car:
    330d
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Jan 2010
    Location
    cardiff
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for the tip. Just been and tried it, the screen where I'd imagine the 'test' should come up is just blank.

    Done a bit more research and think it may be a faulty instrument cluster. The car seems to be running normally, if only I knew a way of testing the cluster?
     
     

  7. Update 
    #5
    Bimmer Fan
    Car Details
    wotzvoltz's Car Details
    Model of Car:
    330d
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Jan 2010
    Location
    cardiff
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Managed to get to a garage today. Diagnostics come up with Code - P1E00 CAN-Bus. It seems nothing is communicating aircon, abs, instrument cluster. Booked in to be repaired now, so fingers crossed shouldn't take long to find. Any one got a heads up on the code, it would be interested to see if anyone else has come across it.
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts