2001 E46 330Ci - electrical gremlin

Notices
 

Thread: 2001 E46 330Ci - electrical gremlin

Reply to Thread
Results 1 to 6 of 6
  1. 2001 E46 330Ci - electrical gremlin 
    #1
    Bimmer Fan
    Car Details
    Andyc79's Car Details
    Model of Car:
    330ci msport
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Nov 2010
    Location
    Uk
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    hi,
    please forgive me for probably going over old ground but i'm stumped.
    after owning this car for about four months the battery died so i replaced it.
    after doing this some warning lights came on whilst driving followed by the battery light which stayed on.
    after reading some posts on here i ran the built in diag test to check voltage which was low (10.2!) so i have replaced the alternator and the battery. Everything was fine for two days when suddenly the warning lights have returned and the car has died again.
    does anyone have any advice on this ?

    thankyou
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    Kevin Whittaker's Car Details
    Model of Car:
    E30 325iSE, E36 M3 convertible and E91 330i Msport
    Year of Manufacture:
    1988, 1997 & 2008
    Transmission Type:
    Manual, Manual & Automatic
    Car Body Type:
    Coupe, Convertible & Touring
    Kevin Whittaker's Avatar
    Join Date
    Dec 2008
    Location
    Marford, Wrexham
    Posts
    6,989
    Thanks
    2,910
    Thanked 5,020 Times in 3,812 Posts
    Can anyone assist the OP with this issue?
     
     

  4.  
    #3
    BMW Crazed
    Car Details
    hugo318iss's Car Details
    Model of Car:
    318is M42
    Year of Manufacture:
    1995
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    hugo318iss's Avatar
    Join Date
    Sep 2010
    Location
    Currently Wrexham, but between here n Hampshire
    Posts
    171
    Images
    5
    Thanks
    161
    Thanked 68 Times in 55 Posts
    snds like you've got wires touching somewhere and its draining the battery, not familiar with E46s though so couldn't suggest the obvious places to look

    EDIT: apparently after the Final Stage Resistor (FSR) can be a common culprit to do with battery drain on the E46. if i understand correctly its part of your heating system
    318IS PROJECT
    On the to do list:
    Fit: Supercharger, New exhaust - get a twin pipe, Vibe front speakers , Front splitter repair/respray install

    To do :Poss refurb wheels, Sort dents, Put front lights back to OEM, Respray, Remap

    Sideways is the only way forward
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    BMW Guru
    Car Details
    shamM3's Car Details
    Model of Car:
    318i
    Year of Manufacture:
    1997
    Transmission Type:
    Manual
    Car Body Type:
    Vert
    shamM3's Avatar
    Join Date
    Aug 2009
    Location
    West Yorkshire
    Posts
    4,071
    Thanks
    950
    Thanked 1,502 Times in 1,391 Posts
    Its common on the e36 for the wires running between the rear quarter and boot lid to become frayed, could be the same on a e46 so a good place to check. Other than that check for a parasitic drain and make sure the car goes into sleep mode after 20mins
     
     

  7.  
    #5
    BMW Guru
    Car Details
    shamM3's Car Details
    Model of Car:
    318i
    Year of Manufacture:
    1997
    Transmission Type:
    Manual
    Car Body Type:
    Vert
    shamM3's Avatar
    Join Date
    Aug 2009
    Location
    West Yorkshire
    Posts
    4,071
    Thanks
    950
    Thanked 1,502 Times in 1,391 Posts
    You haven't recently changed a stereo or anything else?
     
     

  8.  
    #6
    Bimmer Fan
    Car Details
    Andyc79's Car Details
    Model of Car:
    330ci msport
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Nov 2010
    Location
    Uk
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    no i havn't changed the audio system and iv'e managed to fry my multi-meter. happy days!
    i appreciate your feedback guys i'm going to start checking any accessible wiring for defects etc.
    all the fuses check out ok and the only electrical device that dosn't work is the passenger side heated seat so i may start there.

    thanks
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts