2001 E46 330ci - console woes!!

Notices
 

Thread: 2001 E46 330ci - console woes!!

Reply to Thread
Results 1 to 10 of 10
  1. 2001 E46 330ci - console woes!! 
    #1
    BMW Fanatic
    Car Details
    EC8_civic's Car Details
    Model of Car:
    330Ci
    Year of Manufacture:
    2001
    Transmission Type:
    5 Speed
    Car Body Type:
    Coupe

    Join Date
    Oct 2009
    Location
    malta
    Posts
    43
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Guys been having some problems with the console of lately and not sure what the problem is.

    Issue 1: Normal driving, spedo, revcounter, petrol gauge start blipping as in a clock/watch second hand. I drive some more, whole console restarts, trip counter is zerod. Drive some more console just shuts down, no light no gauges.

    Issue 1.1: I try to fiddle with the fuses, none blown, but it seems i reset something console now working normally.

    Issue 1.2: Parking aid and gong never functioned, after the reset and fiddling with the fuse panel i now here a gong when i ingage reverse (altough sensors still dont work).

    Issue 2: All seemed to work for a week or so, now it all happened again. Re tried seeing the fuses all are fine, altough i notice fuse 10 is missing and i put a new one (nothing changes). I reset everything by pulling the main fuse out, and console is now fine.

    Just as a remark: obc never worked, parking sensors tested in reverse and none click.

    Any clues guys? Cause it's driving me a little crazy.
    Last edited by EC8_civic; 25-06-2011 at 12:01.
    Traction Control.... And where is the fun in that??

     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Fanatic
    Car Details
    EC8_civic's Car Details
    Model of Car:
    330Ci
    Year of Manufacture:
    2001
    Transmission Type:
    5 Speed
    Car Body Type:
    Coupe

    Join Date
    Oct 2009
    Location
    malta
    Posts
    43
    Thanks
    1
    Thanked 0 Times in 0 Posts
    common guys, no ideas at all?

    A friend managed to source me what seems like a 320d cluster, if i replace this to test, how long till the tamper light comes on? and when i remove 320cluster and reinstall mine all be ok right? no tamper whatsoever, will come up on mine?
    Traction Control.... And where is the fun in that??

     
     

  4.  
    #3
    BMW Maestro
    Car Details
    bratty's Car Details
    Model of Car:
    330 Ci
    Year of Manufacture:
    2003
    Transmission Type:
    Auto
    Car Body Type:
    Cabrio
    bratty's Avatar
    Join Date
    Nov 2010
    Location
    Germany
    Posts
    809
    Thanks
    376
    Thanked 535 Times in 429 Posts
    I swapped my MPH cluster to The Original! KMH one on my LHD e46 330 and did not get any tamper indications.

    The problem is the Odometer! because the mileage stays the same as the point when the cluster was removed ie. if your car has 40 000mile on the clock and you fit another cluster and drive it 100 miles!! When you re-fit the original the you will have the same mileage showing at the removal and the distance that you travelled in the car will be recorded in the LCM and key, which makes your car look "clocked" if checked at the dealership.

    I have a 330i MPH cluster if you find that it is at fault.

    Dunk
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    BMW Fanatic
    Car Details
    EC8_civic's Car Details
    Model of Car:
    330Ci
    Year of Manufacture:
    2001
    Transmission Type:
    5 Speed
    Car Body Type:
    Coupe

    Join Date
    Oct 2009
    Location
    malta
    Posts
    43
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I dont realy intend to do much work at the dealers anyhow. Important part is that i dont get a tamper light on my cluster.

    So.. any ideas if the above does or does not point to a faulty cluster?
    Traction Control.... And where is the fun in that??

     
     

  7.  
    #5
    BMW Fanatic
    Car Details
    EC8_civic's Car Details
    Model of Car:
    330Ci
    Year of Manufacture:
    2001
    Transmission Type:
    5 Speed
    Car Body Type:
    Coupe

    Join Date
    Oct 2009
    Location
    malta
    Posts
    43
    Thanks
    1
    Thanked 0 Times in 0 Posts
    New issue!

    I noticed that sometimes the cluster shows a red bulb on the rear right hand side, i say prolly just a blown bulb, but it seams nothing is that easy.

    All the right hand side lights are intermittent and when they do switch on they are dimmer and keep flikering. Could this be the problem thats killing the bus (and thus the cluster)?

    If so how should i go on with solving the problem?
    Traction Control.... And where is the fun in that??

     
     

  8.  
    #6
    Moderator
    Car Details
    thepurpleblob's Car Details
    Model of Car:
    840Ci Sport, 330Ci Clubsport, X3 2.0d SE
    Year of Manufacture:
    1999, 2003, 2004
    Transmission Type:
    Automatic, Automatic, Manual
    Car Body Type:
    Coupe, Coupe, SAV
    thepurpleblob's Avatar
    Join Date
    Aug 2010
    Location
    Carluke, Lanarkshire (nr. Glasgow)
    Posts
    1,963
    Images
    1
    Thanks
    104
    Thanked 448 Times in 407 Posts
    1. Get a meter on the battery. Is the voltage ok (should be over 12V) and is it charging ok when running (14V + ). Low battery voltage can cause all sorts of oddness.

    2. Take the clocks out and have a look. Could be corrosion or something - leaking windscreen? I realise you are in quite a dry place

    3. Get the codes read - you never know what's lurking in the error memory

    4. Switch the clocks. I'm not sure if the clocks in your car will need coded but (at worst) it would be an interesting comparison.
     
     

  9.  
    #7
    BMW Fanatic
    Car Details
    EC8_civic's Car Details
    Model of Car:
    330Ci
    Year of Manufacture:
    2001
    Transmission Type:
    5 Speed
    Car Body Type:
    Coupe

    Join Date
    Oct 2009
    Location
    malta
    Posts
    43
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Voltage is fine, just went through the cluster diagnostics yesterday.

    I'm not so sure i would like to remove the cluster myself, have very little tools at my disposal and very little workspace.

    No codes present, at least no check engine light.

    Im wating for an electrician to source me another cluster to try out, if not ill just purchase myself from www.

    Is the OBC residing in the cluster? or is it an external module?
    Traction Control.... And where is the fun in that??

     
     

  10.  
    #8
    BMW Maestro
    Car Details
    bratty's Car Details
    Model of Car:
    330 Ci
    Year of Manufacture:
    2003
    Transmission Type:
    Auto
    Car Body Type:
    Cabrio
    bratty's Avatar
    Join Date
    Nov 2010
    Location
    Germany
    Posts
    809
    Thanks
    376
    Thanked 535 Times in 429 Posts
    You need to get your battery checked properly, just because the voltage is ok is only part of the story. If some plates inside the battery are distorted or contaminated then as soon as there is a large amperage demand the voltage will drop quicker than normal.

    The cluster takes 5 minutes to change, two screws at the top off the binnacle and pull the top of it gentley at the back there are some plugs which have a locking mechanism, release them and its free,

    Dunk
     
     

  11.  
    #9
    BMW Fanatic
    Car Details
    EC8_civic's Car Details
    Model of Car:
    330Ci
    Year of Manufacture:
    2001
    Transmission Type:
    5 Speed
    Car Body Type:
    Coupe

    Join Date
    Oct 2009
    Location
    malta
    Posts
    43
    Thanks
    1
    Thanked 0 Times in 0 Posts
    For the battery, i have tested it on load and it seems fine, and since its a secluded problem il guess its not related.

    Yesterday night I focused on the rear end light section, and guess what.. theres a burnt connector pin. Can the connector be replaced? since it seems like a molded 1 piece connector?
    Traction Control.... And where is the fun in that??

     
     

  12.  
    #10
    BMW Fanatic
    Car Details
    EC8_civic's Car Details
    Model of Car:
    330Ci
    Year of Manufacture:
    2001
    Transmission Type:
    5 Speed
    Car Body Type:
    Coupe

    Join Date
    Oct 2009
    Location
    malta
    Posts
    43
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Guys, What part should i be looking for since i cant seem to find it on the net

    Its the right hand side, inside boot light section (that holds the brake light, reverse and indicator lights), the cable needs to be replaced aswell since the connector is burned. Can the connector be replaced seperatly or should i replace all the wiring loom to the next connector or wherever it is connected at?
    Traction Control.... And where is the fun in that??

     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts