2001 E46 325Ci - Cluster, heating control and stereo contol illumination not working - Page 2

Notices
 

Thread: 2001 E46 325Ci - Cluster, heating control and stereo contol illumination not working

Reply to Thread
Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15
  1.  
    #11
    Bimmer Fan
    Car Details
    bmwener's Car Details
    Model of Car:
    320d
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Oct 2013
    Location
    Netherlands
    Posts
    7
    Thanks
    1
    Thanked 2 Times in 2 Posts
    Check wiring diagram to find out how illumination is managed: WDS BMW Wiring Diagram System - 3 E46
    Dimming is managed by the Combi cluster. Indicator lights (high-beam, turn indication etc.) are sent via K-bus from lightning module to the combi cluster.
    How the illumination is controlled, I didn't find out yet, but since the K-bus is connected to stereo, AC/Heater panel, lichtning module, combi cluster and more, I suspect the lightning module is malfunctioning.
    Now there must be checked how the other matters are illuminated...
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #12
    Bimmer Fan
    Car Details
    Mr_Beemer's Car Details
    Model of Car:
    325Ci M Sport
    Year of Manufacture:
    2001
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe

    Join Date
    Aug 2013
    Location
    London
    Posts
    11
    Thanks
    3
    Thanked 0 Times in 0 Posts
    I checked last night and nothing dims when I turn the headlights on - just a case of the dials, stereo and ac/heater buttons not illuminating at all. From what I had researched previously I thought it may have been K-BUS related and disconnected the battery overnight, touched postive and negative cables whilst unattached to the battery to fully ground out then reconnected but same issue. Other common faults that cause K-BUS issues such as corroded CD Changer Cable and Electric Seat harness are also fine. If it is the LCM at fault I assume a diagnostic check would pick up on this and I think I am going to have to get one done to get to the bottom of this
     
     

  4.  
    #13
    Bimmer Fan
    Car Details
    Mr_Beemer's Car Details
    Model of Car:
    325Ci M Sport
    Year of Manufacture:
    2001
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe

    Join Date
    Aug 2013
    Location
    London
    Posts
    11
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Now the really weird interesting thing I noticed this morning when driving in to work, it was a bit dark so I had my lights on, pulled into the car park at work and went to put up the handbrake and noticed that all the illumination on the cluster started to work! With the lights still on, as I pulled the handbrake up the illumination went off again. If I put the handbrake all the way down it worked again. Now I fitted a centre console with an arm rest back when I first bought the car - and I'm thinking maybe a wire or something got snagged when fitted and its causing some sort of short circuit or something. Although I have had no fuses blow. It must be something like that unless there's some sort of setting linked to the handbrake and the console illumination?
     
     

  5.  
    #14
    Moderator
    Car Details
    edber's Car Details
    Model of Car:
    E60 520D LCI
    Year of Manufacture:
    2007
    Transmission Type:
    AUTOMATIC
    Car Body Type:
    saloon
    edber's Avatar
    Join Date
    Mar 2012
    Location
    South ireland
    Posts
    4,774
    Images
    6
    Thanks
    616
    Thanked 676 Times in 633 Posts
    The handbrake warning light is linked to the cluster so id start looking at the little switch under the handbrake gaiter.
    You may have shorted an earth wire there.
     
     

  6. The Following User Says Thank You to edber For This Useful Post:

    Mr_Beemer (24-10-2013)

  7.  
    #15
    Bimmer Fan
    Car Details
    Mr_Beemer's Car Details
    Model of Car:
    325Ci M Sport
    Year of Manufacture:
    2001
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe

    Join Date
    Aug 2013
    Location
    London
    Posts
    11
    Thanks
    3
    Thanked 0 Times in 0 Posts
    So took apart the centre console on the weekend and couldn't see any loose wires or shorted/bare wires. All the illumination in the car works with the handbrake fully down - as soon as I pull the handbrake up I lose the illumination!
     
     

Page 2 of 2 FirstFirst 12
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts