2001 E46 325Ci - Cluster, heating control and stereo contol illumination not working

Notices
 

Thread: 2001 E46 325Ci - Cluster, heating control and stereo contol illumination not working

Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. 2001 E46 325Ci - Cluster, heating control and stereo contol illumination not working 
    #1
    Bimmer Fan
    Car Details
    Mr_Beemer's Car Details
    Model of Car:
    325Ci M Sport
    Year of Manufacture:
    2001
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe

    Join Date
    Aug 2013
    Location
    London
    Posts
    11
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Hello,

    I'm experiencing an issue whereby the lighting behind the gauges on the cluster isnt working when I turn the lights on. The digital displays are working fine (i.e. mileage readout and radio) and the steering wheel control buttons illuminate orange just fine. The LCM itself lights up to show the different light positions as do the hazard light and door lock button, however the stereo buttons and climate control buttons do not light up orange.

    I have run the Test 2.0 on the cluster and everything works other than the dials themselves lighting up.

    I have disconnected the battery overnight and reconnected - still same issue.

    I have checked all the fuses and they all look fine too (there are 3 fuses I think can't remember the numbers off hand)

    I have run out of ideas on this and have searched and searched for answers, some posts suggest LCM others suggest GM5 however I dont believe I have the most common symptoms for failure on either of these - I'm happy to be wrong about that - just desperately need to know whats wrong so I can get it fixed.

    Any help advice or guidance would be most appreciated
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Car Details
    Mr_Beemer's Car Details
    Model of Car:
    325Ci M Sport
    Year of Manufacture:
    2001
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe

    Join Date
    Aug 2013
    Location
    London
    Posts
    11
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Anyone?
     
     

  4.  
    #3
    Moderator
    Car Details
    edber's Car Details
    Model of Car:
    E60 520D LCI
    Year of Manufacture:
    2007
    Transmission Type:
    AUTOMATIC
    Car Body Type:
    saloon
    edber's Avatar
    Join Date
    Mar 2012
    Location
    South ireland
    Posts
    4,953
    Images
    6
    Thanks
    636
    Thanked 689 Times in 646 Posts
    Have you maybe got the dimmer thumbwheel on the lcm set to low??
     
     

  5. The Following User Says Thank You to edber For This Useful Post:

    Mr_Beemer (16-10-2013)

  6. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  7.  
    #4
    Bimmer Fan
    Car Details
    Mr_Beemer's Car Details
    Model of Car:
    325Ci M Sport
    Year of Manufacture:
    2001
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe

    Join Date
    Aug 2013
    Location
    London
    Posts
    11
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Dimmer is set to full - when I adjust this all the illumination that does work brightens and dims as normal, however the gauge dials stereo buttons and climate control buttons do not light up at all
     
     

  8.  
    #5
    Bimmer Fan
    Car Details
    bmwener's Car Details
    Model of Car:
    320d
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Oct 2013
    Location
    Netherlands
    Posts
    7
    Thanks
    1
    Thanked 2 Times in 2 Posts
    If the test don't make the dial plates illuminate, I guess the LED's (if I recall correctly) are broken. Are all the dials not lit? Did you check if your cluster at least receives the light switch on signal?
     
     

  9. The Following User Says Thank You to bmwener For This Useful Post:

    Mr_Beemer (16-10-2013)

  10.  
    #6
    Bimmer Fan
    Car Details
    Mr_Beemer's Car Details
    Model of Car:
    325Ci M Sport
    Year of Manufacture:
    2001
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe

    Join Date
    Aug 2013
    Location
    London
    Posts
    11
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Thought it could be just the LED's in the dial plates but then I have lost back lighting/illumination on the stereo buttons, climate control buttons and electric window buttons - I'm sure these all light up orange when headlights are turned on?
     
     

  11.  
    #7
    Bimmer Fan
    Car Details
    bmwener's Car Details
    Model of Car:
    320d
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Oct 2013
    Location
    Netherlands
    Posts
    7
    Thanks
    1
    Thanked 2 Times in 2 Posts
    Do the display's dim when you turn on the lights?
     
     

  12.  
    #8
    Bimmer Fan
    Car Details
    Mr_Beemer's Car Details
    Model of Car:
    325Ci M Sport
    Year of Manufacture:
    2001
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe

    Join Date
    Aug 2013
    Location
    London
    Posts
    11
    Thanks
    3
    Thanked 0 Times in 0 Posts
    The displays that do work (Stereo LCD screen, mileage display LCD screen, steering wheel buttons, LCM, Hazard light button and central locking button) all dim when I use the dimmer control on the LCM
     
     

  13.  
    #9
    Bimmer Fan
    Car Details
    bmwener's Car Details
    Model of Car:
    320d
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Oct 2013
    Location
    Netherlands
    Posts
    7
    Thanks
    1
    Thanked 2 Times in 2 Posts
    Yes, that's right, but do they also dim when you turn on the lights? If that's the case, the cluster gets the light switch on signal and you could confirm it's the LED's that have died.
     
     

  14.  
    #10
    Bimmer Fan
    Car Details
    Mr_Beemer's Car Details
    Model of Car:
    325Ci M Sport
    Year of Manufacture:
    2001
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe

    Join Date
    Aug 2013
    Location
    London
    Posts
    11
    Thanks
    3
    Thanked 0 Times in 0 Posts
    I dont think they do get dimmer when I turn the ligts on althought I will test that tonight when its a little darker to be certain. If it was just the LED's in the cluster then I dont know why the other illuminated buttons are not lighting up
     
     

Page 1 of 2 12 LastLast
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts