2001 e46 325 yellow oil light problem

Notices
 

Thread: 2001 e46 325 yellow oil light problem

Reply to Thread
Results 1 to 6 of 6
  1. 2001 e46 325 yellow oil light problem 
    #1
    Bimmer Fan
    Car Details
    kirky-e46's Car Details
    Model of Car:
    e46 325 CI sport
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    coupe

    Join Date
    Feb 2013
    Location
    wolverhampton, uk
    Posts
    13
    Thanks
    4
    Thanked 0 Times in 0 Posts
    hi
    since ive had my 325 the yellow oil light would cone on after starting engine and stay on for 30 seconds or so then go off but then would randomly keep coming on and going off whilst driving so ive recently changed the oil and fitted a new sensor at the same time but now the light will come on after about five mins of driving and stay on
    is this a faulty sensor? or deos it need to be coded or computer reset?
    really anoying now hope someone knows what the hell is going on! lol
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Super Moderator
    Car Details
    dailydoggy's Car Details
    Model of Car:
    330i
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    saloon
    dailydoggy's Avatar
    Join Date
    Sep 2009
    Location
    UK
    Posts
    12,424
    Thanks
    1,817
    Thanked 5,259 Times in 4,090 Posts
    either low oil or the sensors duff... was it a cheap aftermarket one? cos they are shit usually....
    330i sport a big chunk of berlin...

     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    kirky-e46's Car Details
    Model of Car:
    e46 325 CI sport
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    coupe

    Join Date
    Feb 2013
    Location
    wolverhampton, uk
    Posts
    13
    Thanks
    4
    Thanked 0 Times in 0 Posts
    oil level is fine its making me paranoid i keep checkin it and yea it was a aftermarket one
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Super Moderator
    Car Details
    dailydoggy's Car Details
    Model of Car:
    330i
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    saloon
    dailydoggy's Avatar
    Join Date
    Sep 2009
    Location
    UK
    Posts
    12,424
    Thanks
    1,817
    Thanked 5,259 Times in 4,090 Posts
    you have answered ya own question you should stick to hella level sensors which are OEM BMW..

    Oil level Sensor E46 320i M54 12617508003
    330i sport a big chunk of berlin...

     
     

  7.  
    #5
    Bimmer Fan
    Car Details
    kirky-e46's Car Details
    Model of Car:
    e46 325 CI sport
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    coupe

    Join Date
    Feb 2013
    Location
    wolverhampton, uk
    Posts
    13
    Thanks
    4
    Thanked 0 Times in 0 Posts
    thanks mate was hoping that it wasnt tho! :(
    am learning that aftermarket parts for these are rubbish!
     
     

  8.  
    #6
    Moderator
    Car Details
    edber's Car Details
    Model of Car:
    E60 520D LCI
    Year of Manufacture:
    2007
    Transmission Type:
    AUTOMATIC
    Car Body Type:
    saloon
    edber's Avatar
    Join Date
    Mar 2012
    Location
    South ireland
    Posts
    4,964
    Images
    6
    Thanks
    637
    Thanked 689 Times in 646 Posts
    Hopefully you didn't turn on the ignition with the new sensor fitted and an empty sump during the oil change as
    that would have burned out the element in the sensor.I would check the sensor wiring first before replacing the sensor.
    I have an aftermarket oil level sensor fitted to my car with over a year and a half with no issues.
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts