2001 E46 320i On board computer not working - Page 3

Notices
 

Thread: 2001 E46 320i On board computer not working

Reply to Thread
Page 3 of 3 FirstFirst 123
Results 21 to 28 of 28
  1.  
    #21
    Bimmer Fan
    Car Details
    Runo's Car Details
    Model of Car:
    320ci
    Year of Manufacture:
    10/1999
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Feb 2010
    Location
    Sweden
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    And I can´t see it in the radio now becuse I can´t set in with the right knob because I can't change to clock in the OBC because of the faulty stalk.
    Have I understood it all?
    One more thing. When I stepped through the OBC in test mode the inspection 87000 km lit up Can I get rid of that somehow. Why did that came?
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #22
    Dr of BMW
    Car Details
    eddiee36's Car Details
    Model of Car:
    116i SE & 318ti
    Year of Manufacture:
    2005 & 1999
    Transmission Type:
    All Manual
    Car Body Type:
    Hatch & Compact
    eddiee36's Avatar
    Join Date
    Jan 2009
    Location
    Derby, UK
    Posts
    1,028
    Thanks
    173
    Thanked 406 Times in 310 Posts
    Quote Originally Posted by Runo View Post
    And I can´t see it in the radio now becuse I can´t set in with the right knob because I can't change to clock in the OBC because of the faulty stalk.
    Have I understood it all?
    I see now mate, you need to reset the OBC using the ignition and knob method explained earlier in the thread or just do what i did and disconnect the battery this will display the clock instead of the temp.

    let me know how you get on.
     
     

  4.  
    #23
    Bimmer Fan
    Car Details
    Runo's Car Details
    Model of Car:
    320ci
    Year of Manufacture:
    10/1999
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Feb 2010
    Location
    Sweden
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    OK I´ll try to reset it again tomorrow. I don´t think it will help disconnecting the battery it´s 5 degress F here in Sweden so I assume it will switch to temp directly when I connet the battery.
     
     

  5.  
    #24
    Bimmer Fan
    Car Details
    Runo's Car Details
    Model of Car:
    320ci
    Year of Manufacture:
    10/1999
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Feb 2010
    Location
    Sweden
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I tried again now. I can step through 1 to 19.But I can´t find the clock? How do I reset the OBC so I can set the clock?
     
     

  6.  
    #25
    Bimmer Fan
    Car Details
    Runo's Car Details
    Model of Car:
    320ci
    Year of Manufacture:
    10/1999
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Feb 2010
    Location
    Sweden
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I used the guide here http://www.bimmerforums.co.uk/forum/...button-t36778/. The problem was in the stalk. It cost me £0 to repair just some soldering.
     
     

  7.  
    #26
    Bimmer Fan
    Car Details
    Phil Payne's Car Details
    Model of Car:
    330Ci
    Year of Manufacture:
    2002
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe

    Join Date
    May 2011
    Location
    Sheffield
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    People (like me) keep on finding this thread.

    I have EXACTLY this problem - I can get to 1.7 but on the next press of the odometer button it cycles back to 1.0

    Except for me it's rock solid - I've tried about twenty times and never got as far as the display test at 2.0

    I've found about four posts on various fora with these symptoms but no one seems to have nailed the cause.

    2002/02 E46 330Ci automatic cabriolet.
     
     

  8.  
    #27
    Bimmer Fan
    Car Details
    BroadwayBlueshirt's Car Details
    Model of Car:
    328i
    Year of Manufacture:
    1999
    Transmission Type:
    auto
    Car Body Type:
    coupe

    Join Date
    Jul 2011
    Location
    Scotchland
    Posts
    8
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Runo View Post
    And I can´t see it in the radio now becuse I can´t set in with the right knob because I can't change to clock in the OBC because of the faulty stalk.
    Have I understood it all?
    One more thing. When I stepped through the OBC in test mode the inspection 87000 km lit up Can I get rid of that somehow. Why did that came?
    I realise that this is an old thread but somebody will find it as I did so here is your answer.

    It may help someone in the future.
     
     

  9. Obc issues 
    #28
    Bimmer Fan
    Car Details
    OzzLp's Car Details
    Model of Car:
    320td se compact
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Compact

    Join Date
    Nov 2011
    Location
    Herts
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi newbie here so go easy. I'm new to BMW too.

    Just bought my 320 td compact 2001 reg. Love it to bits but same issue regarding the obc. I read somewhere this could be a sign of speedo clocking. Really hoping I haven't bought a car with 3 times expected mileage!

    Any help in this would be great. I get the temperature abd nothing else too. Going to try the test thing but not sure I really follow.

    Should I bother paying someone to see if the indicator stalk has a connection problem or am I wasting my money. I read somewhere that the burton sometimes just needs resoldering but defo don't want to start taking apart my own steering cluster, airbags terrify me!!

    Bummer experts please assist :-/
     
     

Page 3 of 3 FirstFirst 123
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts