2001 E46 320i On board computer not working - Page 2

Notices
 

Thread: 2001 E46 320i On board computer not working

Reply to Thread
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 28
  1.  
    #11
    BMW Fanatic
    Car Details
    cooolhandluke's Car Details
    Model of Car:
    320i SE
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Saloon
    cooolhandluke's Avatar
    Join Date
    Jul 2008
    Location
    Birmingham
    Posts
    79
    Thanks
    2
    Thanked 0 Times in 0 Posts
    i'll try tomorrow..thanks for all your help..will let you know how i get on.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #12
    Bimmerforums Central
    Car Details
    Boostist's Car Details
    Model of Car:
    E46 320i
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    Boostist's Avatar
    Join Date
    Sep 2004
    Location
    Uk
    Posts
    8,035
    Thanks
    3,347
    Thanked 3,425 Times in 1,481 Posts
    Quote Originally Posted by cooolhandluke View Post
    i'll try tomorrow..thanks for all your help..will let you know how i get on.
    Ok great
    Let us know how you get on.
    Im sure we will get to the bottom of it (eventually )
     
     

  4.  
    #13
    BMW Fanatic
    Car Details
    cooolhandluke's Car Details
    Model of Car:
    320i SE
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Saloon
    cooolhandluke's Avatar
    Join Date
    Jul 2008
    Location
    Birmingham
    Posts
    79
    Thanks
    2
    Thanked 0 Times in 0 Posts
    I managed to get it up to 19 and switch on . its very hit and miss....i can get the 1-1.7 readouts still 2 does somesort of test where everything on the dash lights up and moves around but anything 3 upwards shows me nothing ?
     
     

  5.  
    #14
    Bimmerforums Central
    Car Details
    Boostist's Car Details
    Model of Car:
    E46 320i
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    Boostist's Avatar
    Join Date
    Sep 2004
    Location
    Uk
    Posts
    8,035
    Thanks
    3,347
    Thanked 3,425 Times in 1,481 Posts
    Quote Originally Posted by cooolhandluke View Post
    I managed to get it up to 19 and switch on . its very hit and miss....i can get the 1-1.7 readouts still 2 does somesort of test where everything on the dash lights up and moves around but anything 3 upwards shows me nothing ?
    Sounds to me like your OBC is knackered.....
    Why is it hit and miss exactly?
     
     

  6.  
    #15
    BMW Fanatic
    Car Details
    cooolhandluke's Car Details
    Model of Car:
    320i SE
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Saloon
    cooolhandluke's Avatar
    Join Date
    Jul 2008
    Location
    Birmingham
    Posts
    79
    Thanks
    2
    Thanked 0 Times in 0 Posts
    i can do the same sequence lots of times and one time it will let me go from 1-19 and the rest of the time just scrolls through 1-1.7...if i can get it on to 2 it does the dash board thing and 3 onwards it does nothing...to be honest i only want to be able to press the button on the end of the indicator switch and change the normal features...i cant even get the time up it's stuck on temprature and the time on the stereo just shows --:-- too...........i might buy a new switch......because its obviouslty doing somthing.....thanks for all you help.
    Luke
     
     

  7.  
    #16
    Bimmer Fan
    Car Details
    Runo's Car Details
    Model of Car:
    320ci
    Year of Manufacture:
    10/1999
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Feb 2010
    Location
    Sweden
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi
    I found this tread today I have ecxatly the same problem as this.
    My OBC only shows outside temp but no clock. I have the button on the end of the indicator stalk but nothing happens when it´s pressed. I can get into the testmode.
    My clock on the business CD only shows --:-- but I cant set the time. Is the problem solved anyone that could help plz?
     
     

  8.  
    #17
    BMW Guru
    Car Details
    Deano16v's Car Details
    Model of Car:
    745i
    Year of Manufacture:
    2003
    Transmission Type:
    Auto
    Car Body Type:
    Saloon

    Join Date
    Sep 2008
    Location
    Kent
    Posts
    3,632
    Thanks
    652
    Thanked 1,154 Times in 1,001 Posts
    probably a faulty contact in the switch itself mate. you can either take it apart and check it or replace the stalk, assuming that is your problem.
     
     

  9.  
    #18
    Dr of BMW
    Car Details
    eddiee36's Car Details
    Model of Car:
    116i SE & 318ti
    Year of Manufacture:
    2005 & 1999
    Transmission Type:
    All Manual
    Car Body Type:
    Hatch & Compact
    eddiee36's Avatar
    Join Date
    Jan 2009
    Location
    Derby, UK
    Posts
    1,028
    Thanks
    173
    Thanked 406 Times in 310 Posts
    I had the same problem with mine mate. See below for my guide explaining how to to repair it.

    http://www.bimmerforums.co.uk/forum/...button-t36778/
     
     

  10. The Following User Says Thank You to eddiee36 For This Useful Post:

    Deano16v (23-02-2010)

  11.  
    #19
    Bimmer Fan
    Car Details
    Runo's Car Details
    Model of Car:
    320ci
    Year of Manufacture:
    10/1999
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Feb 2010
    Location
    Sweden
    Posts
    9
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thx for quick answers. I think I´ll do that repair when I change to a multifunction steering wheel. Is this a common problem with the older E46? If I have the button on the stalk I have the OBC? And the OBC should be able to show a clock?
     
     

  12.  
    #20
    Dr of BMW
    Car Details
    eddiee36's Car Details
    Model of Car:
    116i SE & 318ti
    Year of Manufacture:
    2005 & 1999
    Transmission Type:
    All Manual
    Car Body Type:
    Hatch & Compact
    eddiee36's Avatar
    Join Date
    Jan 2009
    Location
    Derby, UK
    Posts
    1,028
    Thanks
    173
    Thanked 406 Times in 310 Posts
    Quote Originally Posted by Runo View Post
    Thx for quick answers. I think I´ll do that repair when I change to a multifunction steering wheel. Is this a common problem with the older E46? If I have the button on the stalk I have the OBC? And the OBC should be able to show a clock?
    Yer the wires rub when you move the indicator stalk and then break over time..
    If you have the button on the indicator stalk then you have the computer.

    The OBC will show the clock its just locked on the temp because the stalk is knackard you need to set it by twisting the right stalk in the clocks so it will display on the radio.
     
     

Page 2 of 3 FirstFirst 123 LastLast
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts