2001 E46 320d - Indicator and side light gremlins

Notices
 

Thread: 2001 E46 320d - Indicator and side light gremlins

Reply to Thread
Results 1 to 4 of 4
  1. 2001 E46 320d - Indicator and side light gremlins 
    #1
    Bimmer Fan
    Car Details
    shindha's Car Details
    Model of Car:
    320D
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Jul 2009
    Location
    Birmingham
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hello All,
    About two weeks ago my rear nearside indicator went out, and before I could replace the bulb the offside rear side light went out, but I noticed that when I switched off the engine and set off on a journey the indicator would be Ok until I used it the first time it would come on then stop. Now it has started to go out as soon as I fire up the dash indicators come on for both lights straight away.

    So yesterday I bought some rear indicator light bulbs and replaced both sides set off on my journey the same again so today I check the fuses I couldnt find one for indicators.

    Does anybody have any ideas what should I check next I was thinking the flasher unit but dont know where to look. I havent yet replaced the rear side light bulb would this help.

    Thanks for any help.
    Last edited by mark@vorny.co.uk; 24-02-2011 at 22:12.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    SlowTech's Car Details
    Model of Car:
    330ci
    Year of Manufacture:
    2003
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    SlowTech's Avatar
    Join Date
    Mar 2009
    Location
    North West
    Posts
    7,044
    Thanks
    3,720
    Thanked 3,799 Times in 3,107 Posts
    Check both right and left rear light wired plugs for heat damage on the brown wire connector, its a common fault on the saloon but also an easy fix
     
     

  4.  
    #3
    Dr of BMW
    Car Details
    530kam's Car Details
    Model of Car:
    530d M Sport
    Year of Manufacture:
    2005
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon
    530kam's Avatar
    Join Date
    Aug 2010
    Location
    Buckinghamshire
    Posts
    1,032
    Thanks
    425
    Thanked 315 Times in 280 Posts
    Also check you have a good Earth connection - corrosion can set in and give you a weak Earth causing funnies. If you can't find the Earth point/screw, I would run another lead from the car body, will do absolutely no harm
    Bavarian Motor Works
    530d M Sport Auto in Carbon Black with Black Leather

    Options: Sat Nav Professional,Bluetooth,Folding rear seats, Playstation II, Sony 10 DVD player, Twin headrest monitors & wireless headphones
    Modifications: De flapped,Spare wheel kit, Falken 452's,retrofit BMW Ipod & full software upgrade
    Wish List: window tints & spoiler
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Bimmer Fan
    Car Details
    shindha's Car Details
    Model of Car:
    320D
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Jul 2009
    Location
    Birmingham
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thank yuo it was the plug and adaptor - both corroded.
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts