2001 E46 318i Touring - Testing electric fan

Notices
 

Thread: 2001 E46 318i Touring - Testing electric fan

Reply to Thread
Results 1 to 3 of 3
  1. 2001 E46 318i Touring - Testing electric fan 
    #1
    BMW Fanatic
    Car Details
    duffsparky's Car Details
    Model of Car:
    E46 318i SE Touring
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Apr 2009
    Location
    Hampshire
    Posts
    66
    Thanks
    3
    Thanked 1 Time in 1 Post
    Hi All,

    Yet another problem with my 318i.

    The electric cooling fan system has an intermitent fault causing the fan not to cut-in when required. Diagnostic code from Autodiagnos scanner states "108 - Activation, electric fan short circuit to B- /electric fan malfunction

    Any one know how to test the electric cooling fan? Fan has a permanent 12V supply and is controlled from ECU with variable pulse width signal via another electronic module attached to the fan mounting frame.

    Regards.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    mark@vorny.co.uk's Car Details
    Model of Car:
    911 C2S
    Year of Manufacture:
    2009
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe
    mark@vorny.co.uk's Avatar
    Join Date
    Sep 2008
    Location
    Appleby Magna, Derbyshire
    Posts
    6,636
    Thanks
    5,139
    Thanked 3,738 Times in 2,697 Posts
    Can anybody assist the OP on this issue ?
    2013, Porsche 911 Carrera 4S, PDK, Sports Exhaust, Chrono, etc, etc

    *removed

    BFUK weekday crew

    PLEASE READ THE POSTING RULES & HOW TO CORRECT THREAD TITLES & THE SELLING RULES
     
     

  4. The Following User Says Thank You to mark@vorny.co.uk For This Useful Post:

    duffsparky (15-05-2010)

  5.  
    #3
    BMW Fanatic
    Car Details
    duffsparky's Car Details
    Model of Car:
    E46 318i SE Touring
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Apr 2009
    Location
    Hampshire
    Posts
    66
    Thanks
    3
    Thanked 1 Time in 1 Post
    Hi Mark,

    Thanks for your efforts, much appreciated.

    I've managed to test the fan and it seems to be fine, the problems appears to be with the coolant temp sensor and or camshaft sensor and the DME module getting its knickers in a twist.
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts