2001 E46 318i - Please Help: Awful performance and intermittant issue

Notices
 

Thread: 2001 E46 318i - Please Help: Awful performance and intermittant issue

Reply to Thread
Results 1 to 6 of 6
  1. 2001 E46 318i - Sluggish Intermittent - UPDATED 28/07 
    #1
    Bimmer Fan
    Car Details
    Goosenufc's Car Details
    Model of Car:
    E46 318i
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Nov 2011
    Location
    UK
    Posts
    5
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Hi all,

    I am new to the site and own a 318i e46 touring with the N42 engine.

    I have owned the car for 6 months and has 160k on the clocks.

    Since I have bought it there has been an intermittant issue with some sort of sensor, (I have been told camshaft/crankshaft position sensor).

    What happens is basically the car is EXTREMELY sluggish 80% of the time, and then the other 20% of the time it works great.

    Now the garage I bought it off said that they have replaced the camshaft sensor but it could be the other one failing (I have never had the EML light on, nor has the car stalled).

    So it worked a bit better for a weeek after that and then back to 80/20 again, at the time i was out of work and thought i would give benifit of the doubt and buy another camshaft sensor when i am working.

    Now that I am working again I bought a D900 OBDII diag machine which brings up the following:

    p3240 Map cooling thermostat circuit open
    (Nothing about camshaft sensor, could this still be camshaft issue and just not showing?)

    I/M Readiness brings up CAT, 02S and AIR in bold.

    Any help greatly appreciated as the car is a danger to drive due to how slow it revs when in its poor mode.
    Last edited by Goosenufc; 28-07-2012 at 12:11.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Car Details
    Goosenufc's Car Details
    Model of Car:
    E46 318i
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Nov 2011
    Location
    UK
    Posts
    5
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Bump, any ideas?
     
     

  4.  
    #3
    Platinum BFuk Member
    Car Details
    mojojojo's Car Details
    Model of Car:
    318i se
    Year of Manufacture:
    2002
    Transmission Type:
    manual
    Car Body Type:
    saloon
    mojojojo's Avatar
    Join Date
    Jan 2011
    Location
    Liverpool
    Posts
    829
    Thanks
    171
    Thanked 288 Times in 249 Posts
    Quote Originally Posted by Goosenufc View Post
    Hi all,

    I am new to the site and own a 318i e46 touring with the N42 engine.

    I have owned the car for 6 months and has 160k on the clocks.

    Since I have bought it there has been an intermittant issue with some sort of sensor, (I have been told camshaft/crankshaft position sensor).

    What happens is basically the car is EXTREMELY sluggish 80% of the time, and then the other 20% of the time it works great.

    Now the garage I bought it off said that they have replaced the camshaft sensor but it could be the other one failing (I have never had the EML light on, nor has the car stalled).

    So it worked a bit better for a weeek after that and then back to 80/20 again, at the time i was out of work and thought i would give benifit of the doubt and buy another camshaft sensor when i am working.

    Now that I am working again I bought a D900 OBDII diag machine which brings up the following:

    p3240 Map cooling thermostat circuit open
    (Nothing about camshaft sensor, could this still be camshaft issue and just not showing?)

    I/M Readiness brings up CAT, 02S and AIR in bold.

    Any help greatly appreciated as the car is a danger to drive due to how slow it revs when in its poor mode.

    Hi and welcome,
    Do the EML and emission (engine) light work? - Come on at ignition.
    re: P3240 - You should check the thermostats electrical connection for dirt/broken wires/ loose connection/ getting power to it, also check the fuse for it in the engine bay electrical box if all is ok then replace the thermostat itself.
    The problems you're having could be caused by a number of things.
    Ideally you need a bmw specific code read.
    Do you know the condition of the ccv? (breather system)
    Has it got the modified timing chain tensioner?
    Any service history, work done etc
    You could try unplugging the MAF sensor to see if it improves the running.
     
     

  5. The Following User Says Thank You to mojojojo For This Useful Post:

    Goosenufc (19-01-2012)

  6. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  7.  
    #4
    Bimmer Fan
    Car Details
    Goosenufc's Car Details
    Model of Car:
    E46 318i
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Nov 2011
    Location
    UK
    Posts
    5
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by mojojojo View Post
    Hi and welcome,
    Do the EML and emission (engine) light work? - Come on at ignition.
    re: P3240 - You should check the thermostats electrical connection for dirt/broken wires/ loose connection/ getting power to it, also check the fuse for it in the engine bay electrical box if all is ok then replace the thermostat itself.
    The problems you're having could be caused by a number of things.
    Ideally you need a bmw specific code read.
    Do you know the condition of the ccv? (breather system)
    Has it got the modified timing chain tensioner?
    Any service history, work done etc
    You could try unplugging the MAF sensor to see if it improves the running.
    Sorry I have took so long to reply!

    How can I check the condition of the CCV? what is it?
    Would the thermostat cause poor response? If so where would i locate the fuse box?
    I don't know about the timing chain... how would I tell?
    Also where is the MAF sensor located?

    Sorry to sound like I havn't got a clue, but its my first BMW and is alot more complicated than my prev vauxhalls lol.

    Also a point to mention it sounds VERY tappy when i first start up, then it goes away after a few seconds... it's now also sometimes "juddering" when pulling away in 1st?
     
     

  8.  
    #5
    Bimmer Fan
    Car Details
    Goosenufc's Car Details
    Model of Car:
    E46 318i
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Nov 2011
    Location
    UK
    Posts
    5
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Bump!

    Since the above the car has now developed an intermittent non starting problem where it just cranks over but doesnt start - if i leave it for a day or so and re-try it will start!

    I have since changed:

    - Intake camshaft sensor
    - Crankshaft sensor

    Diags bring up no other faults.

    Pleasse help as im about to set this car on fire I hate it so much!
     
     

  9.  
    #6
    Bimmer Fan
    Car Details
    Goosenufc's Car Details
    Model of Car:
    E46 318i
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Touring

    Join Date
    Nov 2011
    Location
    UK
    Posts
    5
    Thanks
    1
    Thanked 0 Times in 0 Posts
    *UPDATE*

    I drove to Scotland at the weekend from Newcastle, car got me there and back, however for the whole journey the car would sometimes have power and sometimes not.

    Example:

    - Going up a slight hill in 5th between 40-50mph trying to accelerate at slight/half/full throttle took about 10 seconds to gain 5mph
    - After taking a corner in 3rd, 4th or 5th car was again extremely sluggish to pick up speed (almost dangerous)

    I could hear something that sounded like a very fast high paced ticking coming from drivers side engine area when on throttle, noise only apparent when on throttle.

    Then it would be asif I could feel the engine give an ever so slight kick/bump then I would get power back, likewise another kick/bump would take power away (this kick/bump is very slight and passengers wouldnt notice it)

    HELP!
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts