2001 E46 316ti se, airbag light

Notices
 

Thread: 2001 E46 316ti se, airbag light

Reply to Thread
Results 1 to 8 of 8
  1. 2001 E46 316ti se, airbag light 
    #1
    Bimmer Fan
    Car Details
    ruse19830's Car Details
    Model of Car:
    316 ti se
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    hatchback

    Join Date
    Jan 2010
    Location
    tidworth
    Posts
    5
    Thanks
    3
    Thanked 0 Times in 0 Posts
    my air bag light is always on is there a cheap way of fixing this and will they still deploy?
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Crazed
    Car Details
    baronbloom's Car Details
    Model of Car:
    330c icab 540itouring 330cia
    Year of Manufacture:
    2000/1999/2001
    Transmission Type:
    auto auto auto
    Car Body Type:
    coupe/touring/cab
    baronbloom's Avatar
    Join Date
    Sep 2009
    Location
    st albans uk
    Posts
    110
    Thanks
    0
    Thanked 19 Times in 19 Posts
    it's your seatbelt pre-tensioner.common problem on 3's.
    stephen:330cia/540iT/330i cab
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    ruse19830's Car Details
    Model of Car:
    316 ti se
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    hatchback

    Join Date
    Jan 2010
    Location
    tidworth
    Posts
    5
    Thanks
    3
    Thanked 0 Times in 0 Posts
    whats the best was to get it sorted?
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    BMW Maestro
    Car Details
    nick316ti's Car Details
    Model of Car:
    316ti se
    Year of Manufacture:
    51
    Transmission Type:
    manual
    Car Body Type:
    compact
    nick316ti's Avatar
    Join Date
    Jul 2009
    Location
    exeter
    Posts
    600
    Thanks
    37
    Thanked 163 Times in 128 Posts
    paint it black

    Alpine white
    19" black type1 MUTECS
    ONE OF A KIND
     
     

  7.  
    #5
    Bimmer Fan
    Car Details
    ruse19830's Car Details
    Model of Car:
    316 ti se
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    hatchback

    Join Date
    Jan 2010
    Location
    tidworth
    Posts
    5
    Thanks
    3
    Thanked 0 Times in 0 Posts
    lol cheers think i might investigate further though.
     
     

  8.  
    #6
    BMW Maestro
    Car Details
    Sh0x's Car Details
    Model of Car:
    TT 225 Quattro
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    Sh0x's Avatar
    Join Date
    Jul 2009
    Location
    London
    Posts
    578
    Thanks
    254
    Thanked 98 Times in 83 Posts
    Mine is also on.

    It used to come on randomly and stay on a few hours then go off, usually when I had passengers in the car.

    Now its come on and stayed on, I cant think why?
    Only thing I can think of is my mate adjusting his passengers seat quite a bit (not used to the settings).

    Since mine was a random, self fixing problem before do you think something could be loose? Or once it stays on does it need resetting regardless? What sort of money are we looking at to sort this? Ive got an MOT due soon :(

    Thanks
    Oo (|||)(|||) oO
    Ex E46 Compact Owner
     
     

  9.  
    #7
    BMW Crazed
    Car Details
    binman's Car Details
    Model of Car:
    330d SE
    Year of Manufacture:
    2003
    Transmission Type:
    Manual
    Car Body Type:
    Saloon
    binman's Avatar
    Join Date
    Aug 2009
    Location
    Sandy, Beds
    Posts
    208
    Thanks
    23
    Thanked 154 Times in 111 Posts
    Most likely caused by the occupancy sensor in the passenger seat (especially for you shox) you both need to get your codes read to confirm though.

    Shox you could try disconnecting the battery for 20 mins and then unplugging and replugging the big connector under the passenger seat to see if that fixes it.

    You can see how I used software to detect a faulty occupancy sensor here INPA OBD2 USB Interface review

    I then used the information in this guide to bypass it
    http://web.archive.org/web/200502140...s/Recaros.html

    There is also a guide here for fixing it properly, a new mat is about £60 from the dealer
    http://www.ausbmw.com/tutorials/occupancysensor.pdf

    Just for everyones info, the occupancy sensor detects if a person is sitting in the passenger seat. With the sensor working, if the passenger seat is empty and the vehicle is involved in an accident, the passenger airbag will not fire. The thinking behind this is that it reduces accident repair costs. Using the bypass method is not a safety risk, the bypass mimicks someone stitting in the seat at all times so the passenger airbag will fire in an accident even if the seat is empty.

    NOTE:- By adding a bypass sensor you are altering the airbag system from the manufacturers design, in the event of an accident if your vehicle is inspected this action could invalidate your insurance and lead to problems from the police. The above is provided for information only, I am not recommending you carry out this modification.
    Last edited by binman; 19-01-2010 at 16:43. Reason: disclaimer added
     
     

  10. The Following 2 Users Say Thank You to binman For This Useful Post:

    ruse19830 (11-01-2010),Sh0x (11-01-2010)

  11.  
    #8
    BMW Maestro
    Car Details
    nick316ti's Car Details
    Model of Car:
    316ti se
    Year of Manufacture:
    51
    Transmission Type:
    manual
    Car Body Type:
    compact
    nick316ti's Avatar
    Join Date
    Jul 2009
    Location
    exeter
    Posts
    600
    Thanks
    37
    Thanked 163 Times in 128 Posts
    Quote Originally Posted by Sh0x View Post
    Mine is also on.

    It used to come on randomly and stay on a few hours then go off, usually when I had passengers in the car.

    Now its come on and stayed on, I cant think why?
    Only thing I can think of is my mate adjusting his passengers seat quite a bit (not used to the settings).

    Since mine was a random, self fixing problem before do you think something could be loose? Or once it stays on does it need resetting regardless? What sort of money are we looking at to sort this? Ive got an MOT due soon :(

    Thanks
    mine has been on for around a year now passed MOT with it on.....
    bmw wanted £65 to put it on there diagnostics machine to turn it off so its still on

    Alpine white
    19" black type1 MUTECS
    ONE OF A KIND
     
     

  12. The Following User Says Thank You to nick316ti For This Useful Post:

    Sh0x (11-01-2010)

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts