2000 E46 323i - cd player not working - Page 2

Notices
 

Thread: 2000 E46 323i - cd player not working

Reply to Thread
Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18
  1.  
    #11
    BMW Crazed
    Car Details
    Trung's Car Details
    Model of Car:
    730i SE
    Year of Manufacture:
    2006
    Transmission Type:
    Semi auto
    Car Body Type:
    Saloon
    Trung's Avatar
    Join Date
    Apr 2010
    Location
    Earls Colne, Essex
    Posts
    180
    Thanks
    43
    Thanked 141 Times in 131 Posts
    I got the same problem with mine too. I could hear a quiet mechanical sound when pressing the green eject button but magazine wont come out.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #12
    Bimmer Fan
    Car Details
    markc71's Car Details
    Model of Car:
    325i M Sport
    Year of Manufacture:
    2003
    Transmission Type:
    Auto
    Car Body Type:
    Saloon

    Join Date
    Nov 2009
    Location
    Orkney
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Same problem with my car thought it would be fixed when i took it to BMW garage for service as said there was a fault. Went back to collect the car in evening ' yes there is a fault with cd changer' is it fixed? ' no would need to remove and send to specialist in Falkirk'.

    Looking for simple fix without having to remove it. I have found the following link for those wishing to remove cd changer.

    http://www.carstereohelp.org/stereor...UK00CDChgr.htm
     
     

  4.  
    #13
    Moderator
    Car Details
    thepurpleblob's Car Details
    Model of Car:
    840Ci Sport, 330Ci Clubsport, X3 2.0d SE
    Year of Manufacture:
    1999, 2003, 2004
    Transmission Type:
    Automatic, Automatic, Manual
    Car Body Type:
    Coupe, Coupe, SAV
    thepurpleblob's Avatar
    Join Date
    Aug 2010
    Location
    Carluke, Lanarkshire (nr. Glasgow)
    Posts
    1,872
    Images
    1
    Thanks
    94
    Thanked 442 Times in 401 Posts
    It's not a fuse. It's an internal fault in the changer. There are a number of places in Scotland that specialise in car audio repairs. It might be cheaper to swap it out for an after market unit (they are usually Alpine units and are identical except for the interface). You just need an adaptor - Soundlinx for example.

    EDIT:
    On a 2000 it might be an old-style Pioneer unit. Still should be fixable.
     
     

  5.  
    #14
    Bimmer Fan
    Car Details
    Pesho_T's Car Details
    Model of Car:
    318i
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Nov 2010
    Location
    Trowbridge, Wiltshire
    Posts
    19
    Thanks
    2
    Thanked 4 Times in 3 Posts
    I had a similar problem - the changer wouldn't "swallow" a drawer from the magazine and the display would say "NO MAGAZINE".
    It was caused by one of the gears driving the drawer push/pulling mechanism was out of place and therefore it wouldn't move the mechanism. I've no idea what's caused this but it could be what's causing your problem, just that the gear's been displaced when the CD was inside.
    Anyway it's an old topic and you could have solved it, but if anyone wants more detailed instructions with pictures I'll be more than happy to make one
     
     

  6.  
    #15
    Bimmer Fan
    Car Details
    pedro40's Car Details
    Model of Car:
    330 d m sport
    Year of Manufacture:
    2007
    Transmission Type:
    automatic
    Car Body Type:
    saloon

    Join Date
    May 2010
    Location
    swansea,uk
    Posts
    9
    Thanks
    8
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Pesho_T View Post
    I had a similar problem - the changer wouldn't "swallow" a drawer from the magazine and the display would say "NO MAGAZINE".
    It was caused by one of the gears driving the drawer push/pulling mechanism was out of place and therefore it wouldn't move the mechanism. I've no idea what's caused this but it could be what's causing your problem, just that the gear's been displaced when the CD was inside.
    Anyway it's an old topic and you could have solved it, but if anyone wants more detailed instructions with pictures I'll be more than happy to make one
    hi mate, my cd changer has just flagged up the no magazine on the head unit and will not release magazine any ideas would be greatfull.

    peter
     
     

  7.  
    #16
    Bimmer Fan
    Car Details
    Pesho_T's Car Details
    Model of Car:
    318i
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Nov 2010
    Location
    Trowbridge, Wiltshire
    Posts
    19
    Thanks
    2
    Thanked 4 Times in 3 Posts
    Quote Originally Posted by pedro40 View Post
    hi mate, my cd changer has just flagged up the no magazine on the head unit and will not release magazine any ideas would be greatfull.

    peter
    Hey!

    Can you hear any of the motors moving inside when you press the eject button?
     
     

  8.  
    #17
    Bimmer Fan
    Car Details
    masheard's Car Details
    Model of Car:
    X5 3.0d sport
    Year of Manufacture:
    2005
    Transmission Type:
    Automatic
    Car Body Type:
    Estate

    Join Date
    Aug 2012
    Location
    Stafford, England.
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    It sounds like one of the small drive motors inside the changer is on its way out. There are 3 in all but the one that moves the CD trays tends to form a dead spot and then jams. Its a really common fault with them and can easily be fixed by replacing the one motor. I've done a few on my own X5 and a couple for Friends. The motor is an FF-050SK-11170 DC motor and there's a bloke on E Bay that sells them for £3.99p each if you fancy a bit of DIY.
     
     

  9.  
    #18
    Bimmer Fan
    Car Details
    masheard's Car Details
    Model of Car:
    X5 3.0d sport
    Year of Manufacture:
    2005
    Transmission Type:
    Automatic
    Car Body Type:
    Estate

    Join Date
    Aug 2012
    Location
    Stafford, England.
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Oh sorry, should have said hello first as its my first post, I normally use the forum as a source of information
     
     

Page 2 of 2 FirstFirst 12
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts