2000 e46 320ci - loads off electrical faults

Notices
 

Thread: 2000 e46 320ci - loads off electrical faults

Reply to Thread
Results 1 to 2 of 2
  1. 2000 e46 320ci - loads off electrical faults 
    #1
    Bimmer Fan
    Car Details
    shreckmyers's Car Details
    Model of Car:
    320ci
    Year of Manufacture:
    2000
    Transmission Type:
    manual
    Car Body Type:
    coupe

    Join Date
    Jul 2010
    Location
    doncaster
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi everyone this is my first time on a forum so please bear with me.

    Right here we go lol, it all started about a month ago when i started having the abs and tracion control stop working. Now personaly i dont see this as a problem because the t/c is always off anyway so its just saved me pressing the button every time i get in lol. but now iv got lights coming up all over, i get the yellow engine light, all the break warning light (which are fine as iv just relaced all discs and pads) a side light stops workin, the car randomly unlocks its sefl and my speedo, mpg and fuel gauge have also started playing up. now none off these faults are constant but its beond a joke now. i love my bimmer and i cant cope with the idea that all the money iv already poured into it was for nothing.
    PLEASE HELP LOL
    Thanks in advance and i hope iv covered everything
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Maestro
    Car Details
    izzy_007's Car Details
    Model of Car:
    325
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    coupe

    Join Date
    Feb 2010
    Location
    london
    Posts
    501
    Thanks
    2
    Thanked 86 Times in 82 Posts
    get it hooke dup to a diagnostics, engine light may be caused by lambda sensor. One or more of your abs sensors may be playing up so thats what might have caused the abs and traction control light
    Brake warning light may be due to the low pad warning wire which might have not been connected to your new pads
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts