2000 E46 318iSE dashboard issues

Notices
 

Thread: 2000 E46 318iSE dashboard issues

Reply to Thread
Results 1 to 7 of 7
  1. 2000 E46 318iSE dashboard issues 
    #1
    Bimmer Fan
    Car Details
    alcot33uk's Car Details
    Model of Car:
    318se
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Dec 2010
    Location
    Newark On Trent UK
    Posts
    4
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Hi All,

    First post (please be gentle).

    Been offered a 2000 W 318iSE Saloon 105K on the clock, 5 BMW stamps in the book (last at 95K).

    The last owner says that he has put a new battery in and shorted a contact, this has caused the speedo to stop and the temperature and fuel warning lights to come on. He says that he has looked at the fuses and that none are blown and that he has taken it to a gatage who say that it's a relay that has gone.

    Now I'm not a mechanic but I would like to own this car (really really good condition and good history and cheap!!).

    Am I being bent over regarding this and will I be severely out of pocket?

    Having googled I believe that the speedo is linked to a sensor on the rear wheels? As for the others I need help!!

    Many Thanks in advance, Alex.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Car Details
    alcot33uk's Car Details
    Model of Car:
    318se
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Dec 2010
    Location
    Newark On Trent UK
    Posts
    4
    Thanks
    2
    Thanked 0 Times in 0 Posts
    UPDATE: Saw the car and very impressed.

    The whole dash is dead other than the backlights. Nothing works at all.

    Ideas?
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    coxy789's Car Details
    Model of Car:
    530D M-Sport
    Year of Manufacture:
    2005
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon

    Join Date
    Oct 2010
    Location
    Shrewsbury
    Posts
    13
    Thanks
    1
    Thanked 3 Times in 3 Posts
    the dashboard would not trip from a battery connect change it would of had to be filled with at some point, probably due to the fact the service history is fake and the mileage is alot high than stated.
     
     

  5. The Following User Says Thank You to coxy789 For This Useful Post:

    alcot33uk (31-12-2010)

  6. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  7.  
    #4
    Bimmer Fan
    Car Details
    alcot33uk's Car Details
    Model of Car:
    318se
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Dec 2010
    Location
    Newark On Trent UK
    Posts
    4
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Very cynical but I see your point!

    Any other pointers?
     
     

  8.  
    #5
    Bimmer Fan
    Car Details
    coxy789's Car Details
    Model of Car:
    530D M-Sport
    Year of Manufacture:
    2005
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon

    Join Date
    Oct 2010
    Location
    Shrewsbury
    Posts
    13
    Thanks
    1
    Thanked 3 Times in 3 Posts
    Hi,

    i would suggest going into bmw and asking when it was last serviced at bmw & see if it matchs with the stamps,

    also bmw will be able to tell you if they see the car when the clocks were disconnected.

    hope this help.
     
     

  9. The Following User Says Thank You to coxy789 For This Useful Post:

    alcot33uk (31-12-2010)

  10.  
    #6
    Bimmer Fan
    Car Details
    alcot33uk's Car Details
    Model of Car:
    318se
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Dec 2010
    Location
    Newark On Trent UK
    Posts
    4
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Thanks again Coxy. I have checked the history and it all seems to add up (although a service is overdue, last one 13 months ago).

    Having looked round the forums I have asked him to disconnect the battery for one hour and then reconnect.

    If this doesnt help i have seen instrument clusters on fleabay for £45+

    Oh, forgot to mention that the indicators all work (as do the hazards) but no noise???

    Alex
     
     

  11.  
    #7
    BMW Crazed
    Car Details
    colin.ab's Car Details
    Model of Car:
    530d
    Year of Manufacture:
    2002
    Transmission Type:
    Auto
    Car Body Type:
    Touring

    Join Date
    Dec 2009
    Location
    Berkshire
    Posts
    248
    Thanks
    8
    Thanked 49 Times in 45 Posts
    The indicators work from the light switch centre. The ticking noise does indeed come from the instrument cluster. There is a chance that the cluster has fused internally. PCB type fuse, but that would be a guess.

    You could fit an other cluster from a breakers. The only problem is that you will get the milage tamper dot on the display, as the mileage is stored on the cluster and on another module.

    There are people who will reset the milage for you! Usually they offer to do the job for cash only!!! Strange.
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts