2000 E39 M5 - indicator fault

Notices
 

Thread: 2000 E39 M5 - indicator fault

Reply to Thread
Results 1 to 7 of 7
  1. 2000 E39 M5 - indicator fault FIXED!!! (I hope) 
    #1
    Bimmer Fan
    Car Details
    markmgk's Car Details
    Model of Car:
    e39 M5
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    May 2009
    Location
    N.Ireland
    Posts
    14
    Thanks
    5
    Thanked 5 Times in 5 Posts
    Hi
    My idicators are messing about. when the stalk is in the neutral position, the right indicator is flashing. I cant turn it off. When I indicate left, the left one comes on ok. When I indicate right, the right on comes on sometimes and sometimes the left one comes on! When I dont indicate at all the right one is on! I read on here that it might be the stalk so I got one from a breaker and put it on but it is still doing the same thing. Does anyone know of anything else I could try?
    Thanks
    Mark.
    Last edited by markmgk; 12-02-2010 at 21:19. Reason: Problem was fixed
     
     

  2. The Following User Says Thank You to markmgk For This Useful Post:

    bmcbedworth (08-04-2010)

  3. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  4.  
    #2
    BMW Guru
    Car Details
    Deano16v's Car Details
    Model of Car:
    745i
    Year of Manufacture:
    2003
    Transmission Type:
    Auto
    Car Body Type:
    Saloon

    Join Date
    Sep 2008
    Location
    Kent
    Posts
    3,632
    Thanks
    652
    Thanked 1,154 Times in 1,001 Posts
    any other lighting anomolies mate?
     
     

  5. The Following User Says Thank You to Deano16v For This Useful Post:

    bmcbedworth (08-04-2010)

  6.  
    #3
    BMW Fanatic
    Car Details
    haks's Car Details
    Model of Car:
    530i champainge edition
    Year of Manufacture:
    2003
    Transmission Type:
    auto
    Car Body Type:
    saloon

    Join Date
    Dec 2009
    Location
    london
    Posts
    51
    Thanks
    3
    Thanked 5 Times in 5 Posts
    don't know what the other guys would make of this but sounds like the indicator stalk has a doggy connection
     
     

  7. The Following User Says Thank You to haks For This Useful Post:

    bmcbedworth (08-04-2010)

  8. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  9.  
    #4
    BMW Guru
    Car Details
    Joe9087's Car Details
    Model of Car:
    E46 320ci M-Sport
    Year of Manufacture:
    2003
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    Joe9087's Avatar
    Join Date
    Feb 2009
    Location
    Ipswich
    Posts
    3,446
    Thanks
    1,262
    Thanked 2,701 Times in 2,156 Posts
    I've retitled your thread correctly
     
     

  10. The Following 2 Users Say Thank You to Joe9087 For This Useful Post:

    bmcbedworth (08-04-2010),markmgk (10-01-2010)

  11.  
    #5
    Bimmer Fan
    Car Details
    markmgk's Car Details
    Model of Car:
    e39 M5
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    May 2009
    Location
    N.Ireland
    Posts
    14
    Thanks
    5
    Thanked 5 Times in 5 Posts
    no other problems. all other lights are working fine. indicators still wonky!:-(
    Last edited by markmgk; 12-01-2010 at 23:57.
     
     

  12. The Following User Says Thank You to markmgk For This Useful Post:

    bmcbedworth (08-04-2010)

  13.  
    #6
    Bimmer Fan
    Car Details
    markmgk's Car Details
    Model of Car:
    e39 M5
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    May 2009
    Location
    N.Ireland
    Posts
    14
    Thanks
    5
    Thanked 5 Times in 5 Posts
    took it apart again to look for dodgy connection. it all seems connected ok. looks like i`m gonna have to take it to an auto spark. do they charge much these days? i`ll let you know!
     
     

  14. The Following User Says Thank You to markmgk For This Useful Post:

    bmcbedworth (08-04-2010)

  15.  
    #7
    Bimmer Fan
    Car Details
    markmgk's Car Details
    Model of Car:
    e39 M5
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    May 2009
    Location
    N.Ireland
    Posts
    14
    Thanks
    5
    Thanked 5 Times in 5 Posts
    Well....I took a chance and sent my LCM to Theo at http://www.lcm-repairs.co.uk/index.html on Monday. It arrived back today (Friday) and all seems well He charged me £80 + P&P and it didnt need reprogrammed! I know its early days, but I`m hopeful its fixed for good. Cheers Theo!
     
     

  16. The Following User Says Thank You to markmgk For This Useful Post:

    bmcbedworth (08-04-2010)

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts