2000 E39 523i - Flat battery and various electrical anomilies


Thread: 2000 E39 523i - Flat battery and various electrical anomilies

Reply to Thread
Results 1 to 2 of 2
  1. 2000 E39 523i - Flat battery and various electrical anomilies 
    Bimmer Fan
    Car Details
    Alan1966's Car Details
    Model of Car:
    Year of Manufacture:
    Transmission Type:
    Car Body Type:

    Join Date
    Feb 2012
    Thanked 0 Times in 0 Posts
    Hope this is in the right place and posted correctly - first post ...

    Been experiencing what seems like random electrical issues over the last few months - occasionally the battery would be flat in the morning and a jump start would get it going again. Recently this has become more frequent, but not consistent e.g. left the car for over a week and started first time, 2 days later after driving regularly - flat battery again. This week car has failed to start on every occasion - even after a 150 mile trip and being parked for 6 hours. Battery new in Nov 11.

    Electical issues:
    • Driver door warning - dashboard light warning and sound. Warning light on pretty much constantly - flashes occasionally - 'Ding' sometimes every 3 seconds for entire journey and sometimes nothing - Door sensor changed and door wiring examined - still the same. Disabled interior light as this would come on with the warning while driving.
    • False rear lightbulb warning - checked all bulbs working fine
    • Driver side rear window operates on its own regardless of the window lock button position
    • Speedo sometimes doesn't work
    • Petrol tank range sometime goes mental - going from 300miles to 0 and anywhere inbetween in seconds
    • ABS warning light on - despite being checked out by garage and all working fine.
    • Heating Blower fan sometime stops working for short time (minutes) and then fine again.

    Been looking at various forum posts and likely culprits seem to be either ignition switch, FSU or hedgehog. To be honest not very technical at all so would have to get mechanic to change, but want to avoid an expensive diagnosis cost and wild goose chase changing bits that aren't the problem.

    Would greatly appreciate it if anyone could validate the symptoms and advise on likely cause.

    Everyone is telling me to ditch it and get something else - but I really love this car .

    Any help would be brilliant.


  2. Remove Advertisements

    Bimmer Fan
    Car Details
    urban's Car Details
    Model of Car:
    Year of Manufacture:
    Transmission Type:
    Car Body Type:

    Join Date
    Aug 2010
    Thanked 1 Time in 1 Post
    Check the charge voltage at the battery, should be 12 to 13 volts at idle rising to no more than around 14 to 15volts when engine revved up. if this is ok check the water levels in the cells of the battery for dry cells (if accesible) and top up the water if needed. if it's a maintenance free battery might be worth buying a new one or borrowing one if you can, a new battery should last 3-5 years unless it was a cheap one you installed. also check the tightness of the battery terminals, a whole range of problems can be caused by loose battery terminals.

    I was having quite a few electrical problems caused by an aftermarket towbar that was fitted, removing the electrical components involved in this towbar cured the faults, the light warning is prime for being caused by a dodgy towbar. also even though the bulbs are all working there may be a bulb on its way out causing a strange resistance causing the failed bulb reading to come up or an incorrect wattage bulb fitted.

    regards all the other faults I'd be looking for a bad earth connection or water ingress somewhere, you've also mentioned the other common culprits.

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts