2000 E36 316ti SE - instruments not working

Notices
 

Thread: 2000 E36 316ti SE - instruments not working

Reply to Thread
Results 1 to 2 of 2
  1. 2000 E36 316ti SE - instruments not working 
    #1
    Bimmer Fan
    Car Details
    Danpetty's Car Details
    Model of Car:
    316i SE E36
    Year of Manufacture:
    2000
    Transmission Type:
    Manual
    Car Body Type:
    Compact

    Join Date
    Aug 2009
    Location
    Bradford
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi,

    I was driving home from work yesterday and noticed all my instruments (speedo, rev counter, fuel gauge and temperature) weren't working. Does anyone have any advice as to what the problem may be and how this can be rectified?

    Thanks
    Dan
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Car Details
    xXxStKxXx's Car Details
    Model of Car:
    325i
    Year of Manufacture:
    1993
    Transmission Type:
    man
    Car Body Type:
    saloon

    Join Date
    Apr 2009
    Location
    North London
    Posts
    12
    Thanks
    4,432
    Thanked 6,073 Times in 4,855 Posts
    pull it out and check all everything is plugged in correctly and check the fuses.If its all ok then you may need new clocks-Plenty for sale on Ebay or you could try our forum vendors Quarry motors
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts