1999 Z3 2.0i - Electrical failure

Notices
 

Thread: 1999 Z3 2.0i - Electrical failure

Reply to Thread
Results 1 to 3 of 3
  1. 1999 Z3 2.0i - Electrical failure 
    #1
    Bimmer Fan
    Car Details
    Harvey2222's Car Details
    Model of Car:
    Z3 2.0 Roadster
    Year of Manufacture:
    1999
    Transmission Type:
    Automatic
    Car Body Type:
    roadster

    Join Date
    Aug 2011
    Location
    Rotherham, UK
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I have mistakenly left the key in the ignition of my Z3 2.0 in the off position for about seven days. Now I have no electrics whatsoever although the battery reads full on my charger. Is there a re-set procedure?
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3. Electrical failure 
    #2
    BMW Guru
    Car Details
    lee_h's Car Details
    Model of Car:
    318 ci
    Year of Manufacture:
    2000
    Transmission Type:
    manual
    Car Body Type:
    coupe
    lee_h's Avatar
    Join Date
    Jan 2011
    Location
    middlesbrough
    Posts
    2,250
    Images
    1
    Thanks
    127
    Thanked 970 Times in 837 Posts
    If you don't mind me asking, how did you manage to leave the key in the ignition for 7 days?
     
     

  4.  
    #3
    BFuk Moderator
    Car Details
    Martyn D.'s Car Details
    Model of Car:
    330 ci
    Year of Manufacture:
    2001
    Transmission Type:
    manual
    Car Body Type:
    coupe
    Martyn D.'s Avatar
    Join Date
    May 2009
    Location
    Cambridgeshire
    Posts
    2,681
    Thanks
    2,478
    Thanked 3,484 Times in 2,111 Posts
    Have you tried locking it using the key then unlocking? if that fails try disconnecting the battery for 10 minutes or so then re-connecting
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts