1999 E46 328i - Wiper fault (FIXED)

Notices
 

Thread: 1999 E46 328i - Wiper fault (FIXED)

Reply to Thread
Results 1 to 10 of 10
  1. 1999 E46 328i - Wiper fault (FIXED) 
    #1
    Bimmer Fan
    Car Details
    neil278's Car Details
    Model of Car:
    328i
    Year of Manufacture:
    1999
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon

    Join Date
    Jan 2009
    Location
    Oxfordshire
    Posts
    22
    Thanks
    4
    Thanked 6 Times in 6 Posts
    Hi,

    New to the forums and bmw's

    Just got myself a E46 328i and had the wipers on and after 40 mins of driving they have stopped working on any setting.

    During the 10 min drive home they made 2 more sweps of the window but thats it, they didnt struggle or make any strange sounds also now they have stopped working the washer pump wont always work.

    Have done a few searchs and they point to the wiper relay but cant find any info on where I can find it?

    Not bad considering I've had the car less than 24hrs

    Cheers for any help I will get back to the search engine!!
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,394
    Thanks
    6,198
    Thanked 7,051 Times in 5,322 Posts
    First off welcome to the forum

    Have you checked the fuses?
     
     

  4. The Following User Says Thank You to Ronnie For This Useful Post:

    neil278 (18-01-2009)

  5.  
    #3
    Bimmer Fan
    Car Details
    neil278's Car Details
    Model of Car:
    328i
    Year of Manufacture:
    1999
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon

    Join Date
    Jan 2009
    Location
    Oxfordshire
    Posts
    22
    Thanks
    4
    Thanked 6 Times in 6 Posts
    Thanks for the welcome

    Yes check fuses in glove box 49,52,59 if i rember correctly but they did work for 2 sweeps after they stopped working so relay would sound the best bet.

    Would this make the washer pump play up?

    would I have to get a relay from BMW or are they a universal type of relay?

    My sister owned the car before me and said shes never seen the problem before
     
     

  6. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  7.  
    #4
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,394
    Thanks
    6,198
    Thanked 7,051 Times in 5,322 Posts
    The relay wouldn't make the washers play up, the stalk would though, may be worth getting the codes read for the body control module, there may be a code stored relating to the problem.

    When you turn on the wipers and they don't move, is there any noises from them at all?
     
     

  8.  
    #5
    Bimmer Fan
    Car Details
    neil278's Car Details
    Model of Car:
    328i
    Year of Manufacture:
    1999
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon

    Join Date
    Jan 2009
    Location
    Oxfordshire
    Posts
    22
    Thanks
    4
    Thanked 6 Times in 6 Posts
    Will have a look at the wiper stalk today hopfully it can be removed without the steering wheel coming off

    Theres no noises coming from the wipers when they are on (tryed with engine off to) and they cant be moved when they are in park

    Read with relay they normally start working again so you could be onto somthing here with the stalk
     
     

  9. The Following User Says Thank You to neil278 For This Useful Post:

    xXNealXx (18-01-2009)

  10.  
    #6
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    I had the same symptoms a couple of year ago Neil. Replaced the wiper relay and all good now . You will find it in the E-box located on the left bulk head of the engine bay. You will need an allen key to open the box, and the relay is located on it's own right at the back of the box.
     
     

  11.  
    #7
    Bimmer Fan
    Car Details
    neil278's Car Details
    Model of Car:
    328i
    Year of Manufacture:
    1999
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon

    Join Date
    Jan 2009
    Location
    Oxfordshire
    Posts
    22
    Thanks
    4
    Thanked 6 Times in 6 Posts
    Cheers neal

    where can I get the relay from?
     
     

  12.  
    #8
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    It is no. 4 HERE. I didin't want to mess around with any after market relays, so bought one from the dealer. Cost me something like £9, but todays price is £11.85
     
     

  13. The Following User Says Thank You to xXNealXx For This Useful Post:

    neil278 (18-01-2009)

  14.  
    #9
    Bimmer Fan
    Car Details
    neil278's Car Details
    Model of Car:
    328i
    Year of Manufacture:
    1999
    Transmission Type:
    Automatic
    Car Body Type:
    Saloon

    Join Date
    Jan 2009
    Location
    Oxfordshire
    Posts
    22
    Thanks
    4
    Thanked 6 Times in 6 Posts
    It's the relay

    Turned wipers on taped said relay with a screwdriver and it sprung into life.

    Will get onto a dealer tomorrow morning
     
     

  15.  
    #10
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    Thanks for the update Neil
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts