1999 E46 328Ci OBC only shows temp??

Notices
 

Thread: 1999 E46 328Ci OBC only shows temp??

Reply to Thread
Results 1 to 7 of 7
  1. 1999 E46 328Ci OBC only shows temp?? 
    #1
    Bimmer Fan
    Car Details
    Steveo328's Car Details
    Model of Car:
    328Ci
    Year of Manufacture:
    1999
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Aug 2009
    Location
    Westbury
    Posts
    7
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Can anyone explain why my obc only displays temp

    the bc button on the indicator stalk does nothing when i press it, just stays on temp the whole time (kinda pisses me off as i can't use any of the other options or have a clock, have to keep checking my phone)

    is ther anyway i can reset the obc? or is ther a way to find out if the button on the stalk is knackered??

    didnt bother me at first, now is getting on my nerves a bit

    any help greatly appricaited, thanks
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Dr of BMW
    Car Details
    eddiee36's Car Details
    Model of Car:
    116i SE & 318ti
    Year of Manufacture:
    2005 & 1999
    Transmission Type:
    All Manual
    Car Body Type:
    Hatch & Compact
    eddiee36's Avatar
    Join Date
    Jan 2009
    Location
    Derby, UK
    Posts
    1,028
    Thanks
    173
    Thanked 406 Times in 310 Posts
    mine is the same mate what temp are you displaying?
     
     

  4.  
    #3
    BMW Guru
    Car Details
    Deano16v's Car Details
    Model of Car:
    745i
    Year of Manufacture:
    2003
    Transmission Type:
    Auto
    Car Body Type:
    Saloon

    Join Date
    Sep 2008
    Location
    Kent
    Posts
    3,632
    Thanks
    652
    Thanked 1,154 Times in 1,001 Posts
    does everything else work, indicators etc? the wires in the stalk can break and then the button obviously stops working. you can either try a new stalk or take it off and see if you can fix it
     
     

  5.  
    #4
    Bimmer Fan
    Car Details
    Steveo328's Car Details
    Model of Car:
    328Ci
    Year of Manufacture:
    1999
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Aug 2009
    Location
    Westbury
    Posts
    7
    Thanks
    2
    Thanked 0 Times in 0 Posts
    yeh everything else on the car is fine and dandy, cruise ac indicators all work, just cant cycle throught the obc as the button just does bugger all

    temp does change with the conditions as its supposed to tho
     
     

  6.  
    #5
    Bimmer Fan
    Car Details
    Steveo328's Car Details
    Model of Car:
    328Ci
    Year of Manufacture:
    1999
    Transmission Type:
    Manual
    Car Body Type:
    Coupe

    Join Date
    Aug 2009
    Location
    Westbury
    Posts
    7
    Thanks
    2
    Thanked 0 Times in 0 Posts
    do you have to get the steering wheel off to get to the stalk im assuming?

    if so i take dis-connecting the battery is a good idea?
     
     

  7.  
    #6
    Bimmer Fan
    Car Details
    hawkeye's Car Details
    Model of Car:
    M3
    Year of Manufacture:
    2003
    Transmission Type:
    manual
    Car Body Type:
    Coupe

    Join Date
    Dec 2009
    Location
    Larne
    Posts
    3
    Thanks
    1
    Thanked 2 Times in 1 Post
    Ive just bought an e46 325i with the same problem. After a lot of hunting about I hadn't been able to find a way to test the button. Luckily I managed to find a wiring diagram for the OBC & the red/yellow wire connected to the back of the instrument cluster on the smaller of the 2 multi-pin connectors controls the paging function on the OBC. By pushing a sewing needle through the insulation on the wire & touching it to ground I was able to step through the functions showing that the OBC was working fine. So looks like a replacement indicator stalk needed or a break in that wire.
     
     

  8. The Following 2 Users Say Thank You to hawkeye For This Useful Post:

    gildersol (04-12-2009),xXNealXx (04-12-2009)

  9.  
    #7
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    That's a pretty good test procedure hawkeye
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts