1999 E46 328 - Need Help Pusher fan runs on full speed - Page 3

Notices
 

Thread: 1999 E46 328 - Need Help Pusher fan runs on full speed

Reply to Thread
Page 3 of 3 FirstFirst 123
Results 21 to 25 of 25
  1.  
    #21
    BMW Crazed
    Car Details
    andriusv's Car Details
    Model of Car:
    e90 330D M Sport
    Year of Manufacture:
    2005
    Transmission Type:
    Automatic
    Car Body Type:
    saloon

    Join Date
    Jun 2009
    Location
    London
    Posts
    122
    Thanks
    0
    Thanked 4 Times in 4 Posts
    yes bmw done it but said that everything ok.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #22
    BMW Crazed
    Car Details
    andriusv's Car Details
    Model of Car:
    e90 330D M Sport
    Year of Manufacture:
    2005
    Transmission Type:
    Automatic
    Car Body Type:
    saloon

    Join Date
    Jun 2009
    Location
    London
    Posts
    122
    Thanks
    0
    Thanked 4 Times in 4 Posts
    Hello,

    I have a problem with my pusher fan on e46 328ci 1999.When I turn the AC on the pusher fan kiks on full speed even when the engine is cold in the morning.
    I have changed the coolant sensor and re-charged AC gas and checked all fuses and they seems ok.
    Have anyone had this problem and what else i can check is there any speed relays etc that regulates the fan speed.

    Thank you for your help.
     
     

  4.  
    #23
    Dr of BMW gildersol's Avatar
    Join Date
    May 2008
    Location
    scotland
    Posts
    1,423
    Thanks
    171
    Thanked 428 Times in 356 Posts
    This is as much as I have on this, hoping it's relevant for your model.

    There are no speed relays involved. The fan has an output stage control unit which controls the seed of the fan determined by the signal received from the DME.
    The fan speed is influenced by the coolant temperature at the radiator outlet and the pressure in the air conditioning system. The fan speed is reduced as the vehicle speed increases.

    The electric fan is driven at maximum speed in the event of a fault in the coolant temperature sensor at the radiator outlet.

    If the coolant sensor is definately good (may be worth checking the wiring for any damage, or maybe there is a problem with the fan/control unit.

    Air con pressure switch may be worth a look.

    Would have thought there would have been fault codes. Did they definately pull the codes from the air con module.

    Just for info, I think the fuse is No.37 (50A)
     
     

  5.  
    #24
    BMW Crazed
    Car Details
    andriusv's Car Details
    Model of Car:
    e90 330D M Sport
    Year of Manufacture:
    2005
    Transmission Type:
    Automatic
    Car Body Type:
    saloon

    Join Date
    Jun 2009
    Location
    London
    Posts
    122
    Thanks
    0
    Thanked 4 Times in 4 Posts
    I checked all wiring myself and the fuse.The bmw said it might be that the fan coupling is not working properly and pusher fan helps to cool the engine but no fauts recorded.I am not sure what fauts they read but they charge me £150 at Bromley bmw dealers.since then i have change the coupling fan still the same.Sometimes it stop running at the full speed for little while and kicks of again like a jet and this when you start the car in the morning cold.
    the pusher fan running at low speed even when snow button is of. I have checked with mates bmw's but on all of them fan not running when snow button is of.
    I don't realy know what else to do as seems like i change every possible part that related to pusher fan or i am missing something.
     
     

  6.  
    #25
    BMW Crazed
    Car Details
    andriusv's Car Details
    Model of Car:
    e90 330D M Sport
    Year of Manufacture:
    2005
    Transmission Type:
    Automatic
    Car Body Type:
    saloon

    Join Date
    Jun 2009
    Location
    London
    Posts
    122
    Thanks
    0
    Thanked 4 Times in 4 Posts
    I checked all wiring myself and the fuse.The bmw said it might be that the fan coupling is not working properly and pusher fan helps to cool the engine but no fauts recorded.I am not sure what fauts they read but they charge me £150 at Bromley bmw dealers.since then i have change the coupling fan still the same.Sometimes it stop running at the full speed for little while and kicks of again like a jet and this when you start the car in the morning cold.
    the pusher fan running at low speed even when snow button is of. I have checked with mates bmw's but on all of them fan not running when snow button is of.
    I don't realy know what else to do as seems like i change every possible part that related to pusher fan or i am missing something.
     
     

Page 3 of 3 FirstFirst 123
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts