1999 E46 328 - Need Help Pusher fan runs on full speed - Page 2

Notices
 

Thread: 1999 E46 328 - Need Help Pusher fan runs on full speed

Reply to Thread
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25
  1.  
    #11
    BMW Crazed
    Car Details
    andriusv's Car Details
    Model of Car:
    e90 330D M Sport
    Year of Manufacture:
    2005
    Transmission Type:
    Automatic
    Car Body Type:
    saloon

    Join Date
    Jun 2009
    Location
    London
    Posts
    122
    Thanks
    0
    Thanked 4 Times in 4 Posts
    Hi,
    just got new fan fitted and still the same problem.
    Anyone knows what else could be.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #12
    BMW Crazed
    Car Details
    andriusv's Car Details
    Model of Car:
    e90 330D M Sport
    Year of Manufacture:
    2005
    Transmission Type:
    Automatic
    Car Body Type:
    saloon

    Join Date
    Jun 2009
    Location
    London
    Posts
    122
    Thanks
    0
    Thanked 4 Times in 4 Posts
    Hi guys,
    is there any speed relays can be faulthy? and this causing fan run full speed.
     
     

  4.  
    #13
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    No relays. Did you get the fan with a new module fitted? If so and the problem still exists, it would seem that the DME is not sending correct signals to the fan.
     
     

  5.  
    #14
    BMW Crazed
    Car Details
    andriusv's Car Details
    Model of Car:
    e90 330D M Sport
    Year of Manufacture:
    2005
    Transmission Type:
    Automatic
    Car Body Type:
    saloon

    Join Date
    Jun 2009
    Location
    London
    Posts
    122
    Thanks
    0
    Thanked 4 Times in 4 Posts
    Hi, yes I got it complete fan with module.
    So do i need reprogram DME or have to get new one
     
     

  6.  
    #15
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    Best thing to do is get some diagnostics done on your car first to to confirm DME faults
     
     

  7.  
    #16
    BMW Crazed
    Car Details
    andriusv's Car Details
    Model of Car:
    e90 330D M Sport
    Year of Manufacture:
    2005
    Transmission Type:
    Automatic
    Car Body Type:
    saloon

    Join Date
    Jun 2009
    Location
    London
    Posts
    122
    Thanks
    0
    Thanked 4 Times in 4 Posts
    The BMW said that everything fine but I know is not as I had a car for 5 years and this started about 2months ago.
     
     

  8.  
    #17
    Bimmer Fan
    Car Details
    xXxStKxXx's Car Details
    Model of Car:
    325i
    Year of Manufacture:
    1993
    Transmission Type:
    man
    Car Body Type:
    saloon

    Join Date
    Apr 2009
    Location
    North London
    Posts
    8
    Thanks
    4,432
    Thanked 6,072 Times in 4,854 Posts
    Quote Originally Posted by andriusv View Post
    The BMW said that everything fine but I know is not as I had a car for 5 years and this started about 2months ago.
    Did they do a diagnostics?Did you get a printout?
     
     

  9.  
    #18
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,394
    Thanks
    6,198
    Thanked 7,051 Times in 5,322 Posts
    Have you had the engine fault codes read AND the heater control fault codes read using a BMW specific scanner? If not both then this is what you need to do
     
     

  10.  
    #19
    BMW Crazed
    Car Details
    andriusv's Car Details
    Model of Car:
    e90 330D M Sport
    Year of Manufacture:
    2005
    Transmission Type:
    Automatic
    Car Body Type:
    saloon

    Join Date
    Jun 2009
    Location
    London
    Posts
    122
    Thanks
    0
    Thanked 4 Times in 4 Posts
    I have notice that fan works even when AC not on but not full speed.Does it shoud work when AC off even why engine is could.Maybe someone had this problem and help me to sort this costy problem that i had for a while.Thanks
     
     

  11.  
    #20
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,394
    Thanks
    6,198
    Thanked 7,051 Times in 5,322 Posts
    Was the engine live running data checked? especially the reading of the engine coolant temp sensor?
     
     

Page 2 of 3 FirstFirst 123 LastLast
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts