1999 E46 323ci - brake wear sensor warning light problem

Notices
 

Thread: 1999 E46 323ci - brake wear sensor warning light problem

Reply to Thread
Results 1 to 9 of 9
  1. 1999 E46 323ci - brake wear sensor warning light problem 
    #1
    BMW Fanatic
    Car Details
    kopkid's Car Details
    Model of Car:
    323ci
    Year of Manufacture:
    1999
    Transmission Type:
    manual
    Car Body Type:
    coupe

    Join Date
    May 2009
    Location
    westmids
    Posts
    49
    Thanks
    23
    Thanked 2 Times in 2 Posts
    hi guys
    i have a 1999 e46 323ci , that i have recently changed the pads all the way round due to the brake sensor light being illuminated .
    i found the rear pads where almost down to metal, so i replaced the pads and the wear sensor as well , the front pads were not too bad but i changed them any way , because they were not down to metal like the rears i did not replace the wear sensor. the problem i now have is the sensor light on the dash is still illuminated.
    any ideas on how to reset this ?
    thanks in advance guys.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmer Fan
    Car Details
    xXxStKxXx's Car Details
    Model of Car:
    325i
    Year of Manufacture:
    1993
    Transmission Type:
    man
    Car Body Type:
    saloon

    Join Date
    Apr 2009
    Location
    North London
    Posts
    8
    Thanks
    4,432
    Thanked 6,073 Times in 4,855 Posts
    Yep you need to have it reset with one of them diagnostic gagdets-I can do it with my carsoft but there are others.There may be another way but I don't know about it
     
     

  4.  
    #3
    Bimmer Fan
    Join Date
    Jul 2008
    Location
    Middlesex
    Posts
    11
    Thanks
    1,817
    Thanked 7,115 Times in 5,338 Posts
    OP, turn on the ignition to position 2 without starting and leave for at least 30 seconds. If there are no problems, the light should go out.
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    Bimmer Fan
    Car Details
    marcoz's Car Details
    Model of Car:
    520 i SE
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Saloon

    Join Date
    Jul 2009
    Location
    Radcliffe Grt Manchester
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi Kop I had the same problem , but after changing the sensors the fault light went out . I think you could still have a faulty sensor .
     
     

  7.  
    #5
    BMW Guru
    Car Details
    Deano16v's Car Details
    Model of Car:
    745i
    Year of Manufacture:
    2003
    Transmission Type:
    Auto
    Car Body Type:
    Saloon

    Join Date
    Sep 2008
    Location
    Kent
    Posts
    3,632
    Thanks
    652
    Thanked 1,154 Times in 1,001 Posts
    what neal said should sort it.
     
     

  8.  
    #6
    BMW Crazed
    Car Details
    DomestosUK's Car Details
    Model of Car:
    325
    Year of Manufacture:
    2007 (57)
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe
    DomestosUK's Avatar
    Join Date
    Sep 2008
    Location
    Manchester
    Posts
    219
    Thanks
    3
    Thanked 12 Times in 11 Posts
    I was just about to post about this - just had my front pads done - its a fiddly sensor to back in the pad while in the caliper. I had to glue mine :( hope it doesnt **** it up. I'm gonna try Neals advice regarding extinguishing the brake light. Fingers crosses and I post back in a moment
     
     

  9.  
    #7
    BMW Crazed
    Car Details
    DomestosUK's Car Details
    Model of Car:
    325
    Year of Manufacture:
    2007 (57)
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe
    DomestosUK's Avatar
    Join Date
    Sep 2008
    Location
    Manchester
    Posts
    219
    Thanks
    3
    Thanked 12 Times in 11 Posts
    :( Didn't work... I must have a faulty sensor... Anyone know where I can get a new one?
     
     

  10.  
    #8
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,394
    Thanks
    6,198
    Thanked 7,051 Times in 5,322 Posts
    Quote Originally Posted by DomestosUK View Post
    :( Didn't work... I must have a faulty sensor... Anyone know where I can get a new one?
    Euro car parts, GSF, or the main dealers

    The sensor only needs to have the smallest knick taken out of it and it breaks the wire
     
     

  11.  
    #9
    Banned
    Car Details
    fingz999's Car Details
    Model of Car:
    323 SE E46
    Year of Manufacture:
    1999
    Transmission Type:
    manual
    Car Body Type:
    Saloon

    Join Date
    Mar 2009
    Location
    Shropshire
    Posts
    432
    Thanks
    69
    Thanked 94 Times in 69 Posts
    kopkid did you ever sort this?
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts