1999 E39 540i ecu problems. won't start

Notices
 

Thread: 1999 E39 540i ecu problems. won't start

Reply to Thread
Results 1 to 3 of 3
  1. 1999 E39 540i ecu problems. won't start 
    #1
    Bimmer Fan
    Car Details
    Jim bob's Car Details
    Model of Car:
    KEII
    Year of Manufacture:
    1988
    Transmission Type:
    Manual
    Car Body Type:
    Hot Hatch

    Join Date
    Mar 2011
    Location
    Australia
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi everyone,

    My bro's e39 has developed some problems.

    This is what we have worked out so far,

    - Car will not start

    - scanned for fault codes using a 'memoscan' chinese obdII scanner

    - ecu communicates. no DTS codes, no general codes. According to ecu there is nothing wrong. no fault codes registered

    - the scanner has a live data function. according to that all systems go. maf reads airflow on starter, reading ignition advance on operation of starter, reading coolant temp. Fuel sys 1 and sys 2 in open loop. appears all systems go

    - no spark

    - no operation of fuel pump/no fuel pressure on starter operation. pump tests ok

    - After many attempts to start we got 1 fault code related to thermostat. Cleared it and all ok. no repeat. That at least proves the system is functioning... but no start?

    any ideas anyone? We are thinking the ecu is toast but the fact that it comminicates ok with the scanner, has no fault codes and registers readings from all systems under live data is making me think that the ecu might be ok and something else is wrong?

    all help appreciated. thanks
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    BMW Guru
    Car Details
    mark@vorny.co.uk's Car Details
    Model of Car:
    911 C2S
    Year of Manufacture:
    2009
    Transmission Type:
    Automatic
    Car Body Type:
    Coupe
    mark@vorny.co.uk's Avatar
    Join Date
    Sep 2008
    Location
    Appleby Magna, Derbyshire
    Posts
    6,636
    Thanks
    5,139
    Thanked 3,738 Times in 2,697 Posts
    Can anybody assist the OP ?
    2013, Porsche 911 Carrera 4S, PDK, Sports Exhaust, Chrono, etc, etc

    *removed

    BFUK weekday crew

    PLEASE READ THE POSTING RULES & HOW TO CORRECT THREAD TITLES & THE SELLING RULES
     
     

  4.  
    #3
    BMW Guru
    Car Details
    TheEnd's Car Details
    Model of Car:
    540
    Year of Manufacture:
    1998
    Transmission Type:
    Auto
    Car Body Type:
    Saloon
    TheEnd's Avatar
    Join Date
    Jun 2010
    Location
    Birmingham
    Posts
    8,981
    Thanks
    478
    Thanked 2,990 Times in 2,440 Posts
    Maybe you have cam and crank sensors both dead.
    If that happens, the ECU doesn't even know the engine is moving, and will sit there waiting to see it spinning.
    Cranking is a sign that the Immobiliser is happy with the key, but the rest is similar to what would happen if the ECU was changed, or the immobiliser was unsynchonised.

    They would however store code.
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts