1999 E39 523i Fuel and outside temperature gauge

Notices
 

Thread: 1999 E39 523i Fuel and outside temperature gauge

Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. 1999 E39 523i Fuel and outside temperature gauge 
    #1
    Bimmer Fan
    Car Details
    4400's Car Details
    Model of Car:
    320D
    Year of Manufacture:
    2005
    Transmission Type:
    Manuel
    Car Body Type:
    Saloon

    Join Date
    Jul 2008
    Location
    Newcastle-Under-Lyme, Staffordshire
    Posts
    8
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Several months ago my outside temperature suddenly displayed "-40 degrees" and my climate control stopped working properly, including a complete lack of air conditioning. Also once that the tank of fuel was refilled a few days later but it stayed on empty with the fuel light on.........both very annoying prblems.

    I replaced the outside temperature sensor, but that didn't solve the problem.
    I then bought a second hand instrument panel (not knowing that you're not suppose to change them) and fitted it.........BINGO!.. it cured it, but only for 1 week when it reverted back to the original two faults.

    I took it to an independent BMW specialist(together with my old panel) who checked the fuel sender unit/wiring and said that it was functioning OK, but they couldn't cure the faults.
    I have also took it to a BMW main dealer who spent an hour on it and couldn't find the fault and would me to authorise a further £300 of diagnostic cash.

    Any ideas??

    Gaz.
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    RYM
    RYM is offline
    Legendary BFuk Member
    Car Details
    RYM's Car Details
    Model of Car:
    325tds
    Year of Manufacture:
    1996
    Transmission Type:
    Manual
    Car Body Type:
    Touring
    RYM's Avatar
    Join Date
    Apr 2008
    Location
    Bristol
    Posts
    12,959
    Thanks
    5,540
    Thanked 4,935 Times in 3,119 Posts
    You can get diagnostic scans done for around 40 quid

    Take a look here http://www.bimmerforums.co.uk/forum/...and-why-t2383/
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    4400's Car Details
    Model of Car:
    320D
    Year of Manufacture:
    2005
    Transmission Type:
    Manuel
    Car Body Type:
    Saloon

    Join Date
    Jul 2008
    Location
    Newcastle-Under-Lyme, Staffordshire
    Posts
    8
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Both the independent and main dealer tried the diagnostic system with no joy.

    :-((
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    RYM
    RYM is offline
    Legendary BFuk Member
    Car Details
    RYM's Car Details
    Model of Car:
    325tds
    Year of Manufacture:
    1996
    Transmission Type:
    Manual
    Car Body Type:
    Touring
    RYM's Avatar
    Join Date
    Apr 2008
    Location
    Bristol
    Posts
    12,959
    Thanks
    5,540
    Thanked 4,935 Times in 3,119 Posts
    Did they say there weren't any codes stored on the ECU or did they say they couldn't gain access to the codes?
     
     

  7.  
    #5
    Bimmer Fan
    Car Details
    4400's Car Details
    Model of Car:
    320D
    Year of Manufacture:
    2005
    Transmission Type:
    Manuel
    Car Body Type:
    Saloon

    Join Date
    Jul 2008
    Location
    Newcastle-Under-Lyme, Staffordshire
    Posts
    8
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Sorry, I don't know. I'd have to get back them to see if they logged what they did.

    Is there a difference??
     
     

  8.  
    #6
    RYM
    RYM is offline
    Legendary BFuk Member
    Car Details
    RYM's Car Details
    Model of Car:
    325tds
    Year of Manufacture:
    1996
    Transmission Type:
    Manual
    Car Body Type:
    Touring
    RYM's Avatar
    Join Date
    Apr 2008
    Location
    Bristol
    Posts
    12,959
    Thanks
    5,540
    Thanked 4,935 Times in 3,119 Posts
    If the equipment cannot make contact with the ecu then there may be codes stored that they cannot access.

    If there were no codes stored then this could be an issue and may require process of elimination.
     
     

  9.  
    #7
    Bimmer Fan
    Car Details
    4400's Car Details
    Model of Car:
    320D
    Year of Manufacture:
    2005
    Transmission Type:
    Manuel
    Car Body Type:
    Saloon

    Join Date
    Jul 2008
    Location
    Newcastle-Under-Lyme, Staffordshire
    Posts
    8
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Ok.
    Thanks.
    I'll have to ring them tomorrow to see if they got a log of what they did(or didn't do!)
     
     

  10.  
    #8
    Bimmerforums Central
    Car Details
    Boostist's Car Details
    Model of Car:
    E46 320i
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    Boostist's Avatar
    Join Date
    Sep 2004
    Location
    Uk
    Posts
    8,035
    Thanks
    3,347
    Thanked 3,428 Times in 1,481 Posts
    Quote Originally Posted by 4400 View Post
    Ok.
    Thanks.
    I'll have to ring them tomorrow to see if they got a log of what they did(or didn't do!)
    That would be very useful.
    Possibly no faults were recorded however.

    Sounds definately like a wiring issue..... where abouts are you located? I iwill see if theres a good auto sparky who knows BMWs near to you.


    Avoid the main dealer at all costs...we can help you sort this out
     
     

  11.  
    #9
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,398
    Thanks
    6,198
    Thanked 7,052 Times in 5,322 Posts
    The -40 degrees is the default setting when the sensor or wiring has broken, so if the sensor was replaced then it looks as if you have a wiring fault, you should check for power(voltage) at the wires. I would also check all the fuses just in case.
     
     

  12.  
    #10
    Bimmer Fan
    Car Details
    4400's Car Details
    Model of Car:
    320D
    Year of Manufacture:
    2005
    Transmission Type:
    Manuel
    Car Body Type:
    Saloon

    Join Date
    Jul 2008
    Location
    Newcastle-Under-Lyme, Staffordshire
    Posts
    8
    Thanks
    3
    Thanked 0 Times in 0 Posts
    Sorry for late response.
    Fault codes only came up as "instrument panel fault", nothing else apparently.
    There is voltage at the temp gauge connector, and the reading does change a little when I unplug/plug in.
     
     

Page 1 of 2 12 LastLast
Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts