1999 E39 520i - ABS and Traction Control Warning Light

Notices
 

Thread: 1999 E39 520i - ABS and Traction Control Warning Light

Reply to Thread
Results 1 to 4 of 4
  1. 1999 E39 520i - ABS and Traction Control Warning Light 
    #1
    Bimmer Fan
    Car Details
    d7rny's Car Details
    Model of Car:
    520i se
    Year of Manufacture:
    1999
    Transmission Type:
    Manual
    Car Body Type:
    saloon

    Join Date
    Oct 2008
    Location
    North Wales
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi, i have a 1999 5 series saloon, e39. the abs and traction control lights are lit. when plugged into the computer Snap -On Diagnostic, it tells me there is a fault with abs? I have changer the bearing and the abs sensor for that side and reset all codes, but the abs and traction control work for about 2 mins then the lighhts come back on again. Any Ideas??


    Cheers For your help guys and Gals

    Will
     
     

  2. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  3.  
    #2
    Bimmerforums Central
    Car Details
    Boostist's Car Details
    Model of Car:
    E46 320i
    Year of Manufacture:
    2001
    Transmission Type:
    Manual
    Car Body Type:
    Coupe
    Boostist's Avatar
    Join Date
    Sep 2004
    Location
    Uk
    Posts
    8,035
    Thanks
    3,347
    Thanked 3,428 Times in 1,481 Posts
    Quote Originally Posted by d7rny View Post
    Hi, i have a 1999 5 series saloon, e39. the abs and traction control lights are lit. when plugged into the computer Snap -On Diagnostic, it tells me there is a fault with abs? I have changer the bearing and the abs sensor for that side and reset all codes, but the abs and traction control work for about 2 mins then the lighhts come back on again. Any Ideas??


    Cheers For your help guys and Gals

    Will
    Will

    When you say youve changed the ABS sensor for 'that side'..do you mean that the fault code pinpointed which side the problem was on?

    Have you had the other ABS sensors tested?
    Get them to test the resistance of the new one (from connecting plug to the tip of the sensor) and compare it to readings from the other three.

    A variation of more than 15% in resistance on any one sensor points to a fault with that sensor.

    if all the other sensors are ok, have you had the ABS control unit checked out?

    I will look on the BMW Tech system tomorrow and see what other info there is,.
     
     

  4.  
    #3
    Bimmer Fan
    Car Details
    d7rny's Car Details
    Model of Car:
    520i se
    Year of Manufacture:
    1999
    Transmission Type:
    Manual
    Car Body Type:
    saloon

    Join Date
    Oct 2008
    Location
    North Wales
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi, and thanks for your quick response. Yes the machine pinpointed front drivers side. i will test the resistance, or get the sensors off and ask someone to do this for me.

    Thanks for your help
     
     

  5. Remove Advertisements
    BimmerForums.co.uk
    Advertisements
     

  6.  
    #4
    BMW Guru
    Car Details
    Ronnie's Car Details
    Model of Car:
    See above
    Year of Manufacture:
    Never too old, never too new
    Transmission Type:
    Always manual
    Car Body Type:
    Usually 5 doors
    Ronnie's Avatar
    Join Date
    Dec 2007
    Location
    Bournemouth, Dorset.
    Posts
    20,398
    Thanks
    6,198
    Thanked 7,052 Times in 5,322 Posts
    IIRC the resistance is either 1000 or 1100 ohms, you will soon see when compared to each other
     
     

Tags for this Thread

View Tag Cloud

Posting Permissions
  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts